Printer restarting


#1

Hi guys,

hoping someone can help me out, i just got my 3in1 last week, i have used the laser module with great sucess.

but today i tried to use the 3D print module, with no sucess at all.

the problem that i have is, when ever i import a G-code and get all the settings done, then click print the unit turns itself off and back on again,

what could be the problem? How can i reslove it so i can print?

any help you can give would be great.


#2

Could you please provide more details? For example, the first 30 lines in the G-Code file. Is the G-Code imported using SD card or snapmakerjs (version = ?) ?


#3

Hi stanleelxp,

The G-code was generated using the snapmaker software downloaded from there site.

I have tried connecting to the print with both computers using cables supplied and also by putting the GCode on a USB stick.

Both have the same result the printer turns off and back on again


#4

Hi, garry,

Could you pleaser, upload the G-Code file or the 3d model or the website link here (if too big, the first 30 lines in the G-Code file may be sufficient)? Is the software version 2.5.5?:thinking:


#5

here is the first dozen or so line of the code and the software version is 2.6.1

;FLAVOR:Marlin
;TIME:6666
;Filament used: 0m
;Layer height: 0.2

;Generated with Cura_SteamEngine 3.6.0
M82 ;absolute extrusion mode
;Start GCode begin
M104 S200 ;Set Hotend Temperature
M140 S50 ;Set Bed Temperature
M109 ;Wait for Hotend Temperature
M190 ;Wait for Bed Temperature
G28 ;Home
G90 ;absolute positioning
G1 X-4 Y-4
G1 Z0 F3000
G92 E0
G1 F200 E20
G92 E0
;Start GCode end
G92 E0
G1 F1500 E-6.5
;LAYER_COUNT:15


#6

here is the full G-code that the snapmakerjs created from the base image I used

burtonskull_fob_3mm_smaller_20191026221843030.gcode (1.7 MB)

here is the image file im trying to print

burtonskull_fob_3mm_smaller.stl (972.9 KB)


#7

Did you setup your Snapmaker Cura profile correctly? It doesn’t look like you did. I see the G28 ;Home, but not the G1 or G0 lines afterwards.


#8

The G-Code File downloaded is excutable. Sorry. Maybe something wrong with the firmware?:thinking: