Printer Nozzle Jamming

Sorry if this topic comes up a lot, but I’ve been through a lot of the posts and tried the fixes and am still having issues.
It started with the age old print gone wrong- lifted up from the platform overnight and got the printer head all clogged up with plastic. Dug all that out and the head seemed fine, but the original hot end was done for. Replaced it with the spare that came with the printer and it ran two overnight jobs perfectly. After that it started jamming, no matter what job, no matter how i changed the gcode, it’d just stop extruding at some point in the print and just run over open air for the rest of the job (usually at some point while doing infill I’ve noticed)
I’ve seen that it can be because of heat buildup, so I tried running it at cooler temps, I’ve tried with the enclosure open- both helped run slightly longer, but still jammed before the end.
I’ve tried lowering z hop retraction distance to 1mm, no good.
Took the new hot end out and gave it a clean, noticed the thermistor slipped out with no resistance. Saw some people suggested thermal paste to help keep it in place and in contact with the nozzle to help keep proper temp and avoid heat buildup, so i tried a dab of that on the thermistor before reinserting and reassembling the head, but it jammed almost immediately after the base layers/start of infill.
Is there anything else to try? To look for that might be wrong with the hot end or the printer head? If nothing seems to be helping, is it maybe something wrong with the printer head itself, and requiring replacement of that?


Have you been working with the same filament all through this, or switched out? Any chance the filament is getting stripped by the gears inside the head, which would stop it from feeding?

It’s the same type of filament (the black PLA snapmaker reels that came with the printer), but I did switch out to a new reel towards the end of one of those good prints from the new hot end since the first ran out. I guess it’s possible the new reel might be a bad batch or something, even though it’s from the same manufacturer?
Attached a pic of the last filament that jammed. I do see the topmost notch where the gears seem to strip it down too much a lot when it jams, but it looks to me like it’s trying to cram it though from the bulging bit and it’s just not coming out the nozzle which causes the stripping. I do also usually see a lot of plastic bits in the gears, but I usually blow it clean with some compressed air whenever I refeed.

So many people have had problems with Snapmaker filament, I’d just throw it and buy a well known brand.

If the nozzle jams on the first layer it may be that the nozzle is too close to the print surface, better to start with it a little too high and print with a skirt or brim with sufficient line to allow tuning of the Z height on the fly.

If you’re still having problems heat the nozzle using the loading screen and feed plenty through with the button and examine the quality of the extruded filament. Check for free flowing and consistent thickness, around 0.4mm if you have callipers, if you don’t have callipers feel it while pulling it through your fingers - make sure its cooled a little - or better still, buy some callipers.

BTW retraction and Z hop are two different things. Retraction is the filament being pulled back into the extruder when the nozzle is not printing and is moving to another area or at a level change. This to help prevent plastic drooling out and causing stringing.
Z hop is the lifting of the nozzle above the printed level to try to prevent collisions with what has already been printed.

Hope that helps a little, I know I haven’t addressed why the jams occur after several layers have been printed, hopefully that will prove to be lousy filament.

You need to include your printer settings, especially the nozzle temperature in this case. Also, many of us have not been able to obtain any usable results when using the black Snapmaker PLA , I would suggest a better brand. If the nozzle is clogged, you should use a needle and/or a cold-pull to clear the clog. The picture above shows the complications of a clog, but it doesn’t provide any information into what caused the clog.

The most common reasons for clogging are:

  1. Nozzle too close to the bed, which is easy to see.
  2. Nozzle temperature is too high, and the filament is burning inside the nozzle.
  3. Bad filament. Even the best filament can have a bad batch, and the Snapmaker filament should be considered a cheap/budget filament.
  4. Wet filament. Pretty much all types of filament absorb moisture, some significantly more than others, and each type of filament behaves differently when wet. PLA becomes very brittle when wet, and will break when bent over, if it is wet. If it takes quite a few bends to break PLA, then it most likely is not wet.

Or the opposite, too low and not flowing well.

Few other things that can cause it:

Dirt or dust on filament - especially if you’ve been doing cnc.
Nozzle deformed - if you ran into the bed and it pinched the nozzle close a bit.

Check that the extruder gear doesn’t have filament built up on it. Use some compressed air and if necessary a wire brush to get it off.


Another one is retract, I’ve reduced mine to 2mm as 5mm was to much and I’ve had the filament strip a few times myself

1 Like

Oh really? My first reel and the white reel I had no problems with. Maybe I’ll try out another brand just to see.
First layer is always good now, it’s usually when it gets to the infill that it jams at some point.
Feeding through seems fine. Haven’t checked the size, but it has been consistent and coming out thick enough. Was having that problem where it was only putting out a thin line before changing the hot end, but oddly enough it never jammed then. That much is better with the new hot end.

Had the nozzle originally at 215C, but tried lowering to 200C. Lowering seemed to help, but I’ve had attempts fail early on at 200C. Cooler has seemed to perform better, but when I tried opening the enclosure, the part it was printing split and then the nozzle still clogged.
I’m seeing a couple people saying snapmaker’s filament isn’t good. So I might try a different brand to at least see. But I’ll also try cleaning with a needle just to be sure it’s definitely clear.

Annoyingly after replying I had this issue 3 times in a row after a perfect print eSUN PLA+ (spool is low)

Changed to SM PLA that’s been sitting around and came out fine? (spool also low)

I’m about to embark on a large, multi piece model in ASA-CF and a little worried about abrasion on the toothed gear.

I hope the gear is replaceable…

If you’re good with making a custom puller to get the drive gear off the shaft, it’s replaceable. You will also need to fabricate or find a source to purchase a replacement part.

The best way to describe Snapmaker’s filament quality is “inconsistent”. Some spools are perfectly good. Others turn out to have various QA problems. Swapping to something else can’t hurt.

My theory is that the temperature sensor (thermistor) is assembled with wires that are too short and does not let it sit in the correct location near the pool of molten filament. This can be fixed by bending the heater wires with a kink to make them shorter and therefore the thermistor is closer to where the temperature needs to be measured. I had the same problem but since bending the wires it has not happened again. I am going to lengthen the wires on my spare hot end before using it. I have purchased a special thermal grease to use as we ll once the position is correct.

What I think happens is once the filament starts printing the pool of filament starts to cool, it is not sensed at this stage as the thermistor is too far away and it thinks the temperature is correct. once it senses the wrong temperature it is then too late and the molten filament has started to cool causing the click click on the filament and then the filament won’t feed.

Check your Hot ends. I currently have about 10 replacements that vary from +/- 1.9mm to +/- 2.2 mm in diameter on the inlet. I noticed I have tremendous trouble with the smaller hot end. Constant stringing, inconsistent steps, snagging and so on. I don’t know what to make of it but if you have multiple replacement hot ends, look to see I’d your inlet sizes vary. Try swapping for whatever isn’t in your machine to see if that helps.

Even the hot ends can be significantly inconsistent? Jeez.
Well the problem did start after swapping in a new hot end, so i suppose it could be. I just got a couple more spares as backup, so I suppose I could try swapping out again. The newer ones also seem to have better thermistor wiring too. Just a shame to lose that replacement hot end so quickly.

You’re telling me. Now from the ones that I have, the difference is fairly consistent so this makes me think they updated the hotend along with the new 3D print module. I feel the differences in these hot ends makes them problematic should you put a 1st gen hotend into a 2nd gen module or a 2nd gen hotend into a 1st gen module. Now these are just my assumptions on this as I do have dozens of these hotends and have only noticed the change since opening ones that I purchased in September.

Yes, there are new versions of the hotend (v2 and v2.5 apparently). I’ve only had a v1 and v2 in my hands. See this thread: Opinion on two hotends?

I can confirm that there isn’t any problem of using the new ones in the old printhead. both work perfectly fine for me. Don’t know if the old versions still work in the new print head, but that’s most likely not a big issue as people with new printheads probably won’t end up buying the old versions. (unless some shop had a huge stock left over)
Personally, just based on the looks, I would assume they are interchangeable.

they seem to be interchangeable based on the ones i have, one note of caution the nozzle position may change and necessitate re-adjusting the sensor too (i had to do that)

i will say the v2.5 seem to exhibit more filament curling on extrusion than my v1 nozzles.

Hey all, just wanted to update. Took some time, but I got some hatchbox filament and swapped out the hot end again to one I had just ordered recently (indeed they were different versions), and I FINALLY got a good print. Not sure which thing it was exactly, but at this point I’m just happy it’s working again. Thanks to all who responded with advice!

1 Like