OctoPrint indicates Thermal Runaway Protection Disabled

I am enjoying great printing success on my new A350 using PrusaSlicer 2.2.20alpha with a profile I derived from Luban’s gcode output.

I am currently experimenting with the latest release of OctoPrint to compare it with native WiFi and continue to see a warning that the compiled Marlin gcode interpreter firmware does not activate TRP properly.

Just wondering if this is an artifact of SM’s implementation of the Marlin code, or if a later firmware update might include it, if not present and activated.

I am currently running stock firmware, Snapmaker2_V1.5.2.1_20191228

(I have been avoiding the latest FW due to several issues with apparent hardware failures from some early adopters who upgraded FW to the latest rev.)

Any assistance on this would be gratefully accepted!

Regards,

Jeff

2 Likes

I just got my A350 assembled and it’s printing now. I also just built a PrusaSlicer profile from my first print gcode. Would be nice to compare profiles with you. I have not updated my firmware either. I have not used octoprint with the machine yet so I can’t verify if I would see the same issue with the thermal protections.

Thanks,

Steve

Thanks for finding issue to help us improve the firmware. We have roughly audit the related code.

We add more conditions than default Marlin to do temperature condition check, but unintentionally change the macro name. I think that is the main reason we fail the test. we do think we aren’t make it worse. We will double check to assure that.

2 Likes

So I’m setting up OctoPrint for my A350 and I’m hoping someone can answer a few questions for me or point me in the right direction to find the information myself.

  1. What should I put for Custom bonding box settings for the nozzle cleaning routine?

  2. What changes should I make to the axes if any?

Thank you in advance.

Hey @TrekLurker, you could disable the Octoprint Warning / ThermalRunawayProtection.
In the plugins directory of the octoprint, there is a Plugin called “Printer Safety Check”, if you disable it, there should be no warning anymore.

I think the Printer itself has all security actions onboard in the firmware, you don´t need the Pi for protection.

I have my A350 not yet, so i couldn´t check the issue/workaround.
I run the Snapmaker Original with activated plugin because there is no warning.- so there is a firmware-issue :wink:

Greets Chris

My plugin is disabled and the warning is in fact gone.