Nozzle Temperature error


I contact us because there is something strange in the printer. I have the Snapmaker A350. I have used it for 2 years, just printing with PLA (and everything has been ok), but I decided to change material to PETG (for this material you have to increase the nozzle temp). The problem is that when 3d printer starts any 3d file, in the screen always says NOZZLE TEMP is 215º, but should be 240-245º. Before printing, I check 3d file configuration in 3d printer display, and it says 245º, but when it starts printing, change to 215º.

I tried so many times installing the 3d program Luban and checking configuration, but problem persist. I don’t know if the problem is just the display showing this or is real this temperature. Furthermore, I figured also, checking directly the nozzle configuration, and when I put 245 temp, material start to go down automatically, but this does not happen when 3d printer is preparing after I start the 3d printing, so I suppose that the screen information of nozzle temp is true.

I dont know how to solve this problem. Any help is welcome.


What version of Luban are you using? Did you upgrade recently? Same for the firmware (version, recent upgrades).

Can you attach a gcode file so that we can check the temperature-setting lines to see exactly what they say?

(I would swear someone else reported a similar problem a couple of months ago and it turned out to be a software bug/regression, but my search-fu is failing me.)

Hi, thank you for your reply.

  1. What version of Luban are you using? Did you upgrade recently? Same for the firmware (version, recent upgrades).
    Answer: I tried to download last version and also for machine. Also I checked for update.

I could solve the problem, trying many things. The main one, what I did:

  1. Like I said the problem was not something of the machine (temp sensor, or something like that, why?, because I can graduate the nozzle temp manually from the display in the configuration option.
  2. I tried to change the material of the machine with PLA, and to begin the same work of the PETG that was generating me the problem, but the nozzle temp had the same error. So, I attempted to generate another work with PLA config (with 230 max nozzle temp), and surprise, the was not the error.
  3. I realized that the Luban configuration is generating the error. Last time when I started to try the PETG configuration, I duplicated the PETG-Black Luban standard configuration and I generated a new one that is making the error. But when I made the same thing with the PLA-Black Luban standard configuration, is not making the error when I start any work in the machine.

I attached here the screenshot of Luban.

The conclusion is that there is some bug with the last version of the Luban software.
Some people recommend Cura, I will try it with patience.

Thank for your help.