New settings are not holding

Hi, hoping you will be able to help…
I’ve configures a design with Luban, send it to a USB key and printed it with no problem. Now I want to print it again with a different material and I want to increase the temperature of the nozzle and bed. From the device, I open the file on the USB key, then select the change settings option on the screen, set the new temperatures but then when I click Start, the temperatures always go back to the original settings. If I then try to change the temperature, the machine will still start printing with the original temperatures. The only option I’ve found so far is to pause the print as soon as it start, increase the temperatures and when it reach what I want, then I resume.
Thank you

Luban doesn’t let you work from gcode.
However you can edit the gcode file in any text editor.
Just change the temps there.


I don’t want to adjust the settings in Luban but directly on the device. After I’ve selected the file I want to print, I have that screen

It’s the “Adjust settings” at the bottom of the screen that I’m trying to use, but what ever I do, my new settings don’t stay

Note: this snapshot is from another file, the temperatures are already ok…

Has that “Adjust settings” ever worked? I’ve not had any success, other than z-height.

The Adjust Settings button is solely for the current print. As stated above, the Z Offset does carry over from print-to-print, as it is part of leveling. All of the other settings are transient, and they are supposed to be. If you want to make changes to the GCode, you either need to do it in the slicer, or manually.

To me it seems to be pretty useless…
but I guess it is what it is

Thanks for the explanation

From what I remember is if you change the temperature settings before the print starts it will print the first layer at the original settings then adjust to what you have set it to on the screen for the rest of the print.

That is not an accurate statement. If there are temperature changes in the GCode, they will override any change you make on TouchPad. But you always have the option to override those changes, after they have been executed.


Yes you are technically correct. But within Luban as far as I’m aware you only have the option to set the starting temp, after first layer and the last layer. So if you change it then it will apply after the first layer then go back at the final layer. I’ve seen it happen, I thought the same one time as I had started a print using abs filament settings by mistake. I tried to change the temp but it didn’t change until after the first layer.

You are confusing the issue by talking about Luban, as the OP was simply talking about their use of the TouchPad. Changes made on the TouchPad to not transfer to your USB stick, and files uploaded can’t be downloaded.

Luban uses the Cura engine, but only allows you to use a very small portion of its abilities. However, that doesn’t change anything. What I stated is 100% accurate. Your statements do not offer any additional help, and may confuse those who are new to 3D printing, like the OP.

Ok, some clarification just to make sure we are all on the same page… Here is my problem in a (hopefully) more simpler way

  • Use Luban to create the file (bed temperature at 60 and I don’t touch the gcode)
  • Save it on a USB key
  • Load it in the device
  • Print it (bed temperature at 60)
  • → success!
  • Reload it in the device from the USB key
  • Using the “Adjust settings”, try to change the temperature to 80
  • The device start printing at 60 ignoring the 80 I’ve just entered in the “Adjust settings”
  • → Not obtaining the expected results

My work around:

  • Start the new print
  • as soon as device start printing, I pause the print
  • slide the screen to the left and set the temperature to 80
  • wait until the temperature reach 80
  • resume my print
  • → success!

I don’t want to save it back on the USB key. I just want to print it with a different starting temperature.

@ StusA350 If, like you said, that new setting will only be applied on the 2nd layer, then like I’ve mention, I don’t see the utility of that function as my first layer probably won’t stick on the bed (too cold for PETG)…

@ CNC-Maker Yes the level is working as expected. I understand why it’s carried from a print to another and I think it’s a great idea which makes things a lot simpler.

I also understand that if somebody manually modify the gcode to change the temperature mid print, I this could not be controlled by that “pre adjust settings”. It should only change the original temperature.

So from my (very limited) point of view, this seem to be a defect where both temperatures from that initial setting screen are not taken into account right at the start of the print.

Try changing the temp on the screen AFTER the first layer. Likely the temp is reset in gcode after the first layer is completed. Since Luban has settings for both initial and subsequent layers.

My original print was at 60 degrees for PLA. Now I want to print PETG which need the first layer to 80 degrees to stick to the bed. Waiting after the first layer won’t work as my print won’t stick.

Why don’t want to re-export from Luban with different temp? Then you’re SOL. Can’t blame SM for that.

I’m not blaming anybody…I was just asking that question to see if I was the only one with that issue. For sure regenerating the code would have been the best solution but as my computer is not close to my printer, I thought that option was there to do exactly what I was trying to do.

Now that I see how it behaves, it looks like it’s a bug in the device which should be fix or the option should be removed as nobody would be able to use it as is.

The system is working exactly how it is supposed to be working. It is by no means “useless”, people use it everyday, and is basically the same for all 3D printers. The problem is that you have this misunderstanding of how you think everything is supposed to work, instead of how it actually works, thus the incorrect assumption that there is a bug. I would suggest that you learn how 3D printing works, how the Snapmaker works, and how other printers work. Until you understand the process fully, and how the tools actually work, you won’t know how to use them properly.

1 Like

My understanding is that the “Adjust Settings” options through the touchscreen are supposed to parse the gcode file and adjust the commands that the touchscreen sends to the controller as it prints on a per job basis. This would result in the behavior that @sylayo is expecting. The fact that this is not working this way indicates a bug somewhere, most likely in the touchscreen firmware.

@sylayo , you could try submitting a bug report to support or to github, but I’m not confident that they would fix it anytime soon.

That is a false understanding. Changes made under Adjust Settings do 2 things:

  1. If the print has not started printing AND you have uploaded the Gcode to the TouchPad, it will change the very first temperature setting in the Gcode to the value you set, and ONLY the very first temperature setting. If printing has already started, or you are printing from the USB drive, this will not happen. This is not a function of Marlin (the firmware in the Controller), it is solely a function of the Android application running on the TouchPad.
  2. While printing, it will immediately send a live temperature change to the Controller, but it will not pause the print until that temperature change is achieved. The temperature change will occur while the print it printing. You need to manually pause the print, if you want to wait for the change. This is normal functionality in ALL 3D printers, and is part of the firmware that is running on the Controller (Marlin).

Any other understanding of how this works, is incorrect.

I agree that Marlin does not support this adjustment, hence why I specifically referred to the touch screen modifying commands sent to the controller rather than the controller doing anything different.

When printing using a USB drive, the touchscreen acts as an intermediate layer between the drive and the controller. This is where the adjust settings SHOULD have an effect. The intended function of the adjust settings dialogue seems to be changing the settings of the print you are about to do, or at the very least is how the quick start guide and dialogue itself seem to imply. I can’t verify what you said about this only changing the first temperature at the moment, but if this is the case then I would argue that that would support this interpretation. It only changing the first temperature and not the rest would then be a bug.

I do not disagree about what the current behavior IS, just what it is SUPPOSED to do.

There can be multiple temperature changes during a print, and if it changed more than just the first one, none of the other temperature changes would occur. That would break the purpose of having temperature changes, thus the print would fail. This is the reason why only the very first temperature setting is affected.

If you are somehow able to convince the Snapmaker team to make the changes that you are proposing, and I highly doubt that they will, there are going to be a lot of angry owners. Why? Because the firmware will no longer be working the way that everyone else is expecting it to work, and it will no longer be possible to print complicated prints.