New settings are not holding

Your point 1 describe exactly what I’m trying to do… The adjust settings button (see my previous snapshot) is only available before to start the print so I would expect the print to start with the adjusted temperature but it’s not.
So again to my inexperienced eyes, there seem to be a bug.

By the way, you are absolutely right about my level of expertise in 3D printing. It’s very limited and this is why I’ve submitted my question to this forum. But honestly, I was hoping that somebody would explain to me what I was doing wrong instead of just saying I was wrong… and based on some previous comment:

Has that “Adjust settings” ever worked? I’ve not had any success, other than z-height.

It looks like I’m not the only one who think there is a problem…

I agree. I will not make any further comments as to what the settings should do as the interface and documentation are ambiguous and thus up to interpretation. However, it should do something, either the first temp or the whole print, and it does not do either properly.

It is a bug, you are not doing anything wrong.

If @CNC-Maker means that it is literally just changing the first temp command (as in, just changing the first M140 command and not the M190) this would still be a bug as this would be the incorrect way to implement the feature for the initial printing temperature. Unfortunately, I can not test if this is the case as my printer is currently unavailable.

Take a look at the Gcode file. There can be as many as 3 entries at the beginning of the Gcode to set each temperature, the bed, and the nozzle. There are usually 2 for each, 1 that sets the temperature w/o waiting, then the homing, leveling, and moving the head to its starting point occurs, before the second setting of the temperatures actually waits for the each temperature to reach the set value, 1 after the other. Then the first layer actually actually begins printing.

So, if you are setting the temperature before the first layer begins, and there are 2 settings of each temperature, the second setting is overriding what you set on the TouchPad. If you wait until the first layer starts printing, and then change the temperature, that temperature should hold as long as there are no other temperature changes in the Gcode.

Be aware, that if in the slicer you set a first layer temperature, and a temperature for additional layers, there will be another temperature change at the end of the first layer. Once you learn how everything works, your experiences will get better. I’d suggest watching some YouTube videos from when known people, if you want to learn more.

Best of luck!

P.S. I have been a software engineer for 38+ years, so I can assure you that this is not a bug, and is working as designed.

All my nozzle and bed temperatures were set the same in Luban and my experience does not allow me to change the Gcode yet. I would have expected that setting to change the temperature for my entire print

As stated previously, that is a false assumption, and unrealistic expectation. You need to learn the differences, and purposes of the slicer, TouchPad, and Controller, along with how they work and interact with each other.

Still don’t understand… I only have 1 temperature in my model. Now I go to the setting and change it. The print start again with the original temperature instead of what I’ve just entered in the settings. How should have I expected that?

I would understand if the print would have start with my new value and change to the old value after the first layer (maybe Luban originally added 60 for the first layer and then 60 again for the other layers?) so setting a new temperature at 80 would only be applied to the first layer… but like I just sait that did not work as the print started at 60…

Anyway, looks like I can’t figure that simple function so I won’t use it anymore.

This thing worked in previous versions of the firmware.
They broke it when they made the pause command work.
I wrote to support months ago but they are busy with artisan and don’t care to fix this.