My J1 has gone POP!

My machine is one of the first produced…number 133 if the machine name is anything to go by.

I finally got hold of a couple of Bondtech Copperhead heat breaks and followed the hot end upgrade instructions further down the Forum. After re assembly of the hot end with Volcano blocks and CHT type nozzles I was finally looking forward to trouble free printing. Upon carrying out the first bed levelling step there was a spark/ flash when the nozzle touched the rear calibration disc. I switched off straight away as it tried to touch the disc again. I stripped the hot end back down and it looks like the insulation on either the heater element or the thermocouple had split as caused a wire to short out.

I have had the hot ends apart so many times trying different ways to get the thing to just print the insulation must have perished. If it had just worked as it should then I wouldn’t be in this predicament.

I recovered the wires with heat shrink, reinstalled and switched back on. The machine will now not recalibrate as the left nozzle stops 10mm above the calibration disc. rebooting has no effect and is stuck in reset …
Any ideas out there good people?

Circuit board? Firmware? other component?
Is there a UK Snapmaker distributor I can take it to?
I have spent a small fortune above and beyond the initial cost just to try and get the thing to work…

Help desperately needed, thanks.