Misaligned Layers, Nozzle Nudges and Thermonuclear Meltdowns

Thanks for the update.

My only guess is it has to do with acceleration or print speed.

Could you try and print one at like 50% or 30% speed? You can run the same gcode, but override the work speed from the touchscreen to be slower.

There’s nothing specific in the video I can point to in order to justify why I think it’s speed related, just a feeling.

If this were some kind of missed interrupt handling causing a skipped step, what would the estimate be of its probability? Looks like one in 10^5 or 10^6, just as a rough guess.

You know where this idea comes from, I’m guessing. After looking through some of the source code, I’d easily believe there are long processing steps in interrupt handlers that could cause this kind of thing.

1 Like

@MooseJuice any idea if the shift is in the same direction?

I follow @brent113 about print speed, but please reduce also the travel speed, I saw a pretty fast travel in the video which made sounds when I move with 100mm/s.

Video at 1:25 - 1:40min

The shift has occured in both x and y directions.Previously i felt it was X axis only, but the latest was in Y axis.

That particular print was done on “fast mode”, one of the purple ones was on “high quality” so it was slow and others were normal mode. So while i understand the speed argument, i don’t know that its correct - but i can tie back into this after the next info is shared…

I am using this string to discuss with Edwin, who reviewed the file and believes that the file is okay, and there is an issue with a linear module, but they are not sure which one. The sound put up a red flag I guess.

I have extra modules, so he says i should trade the Y axis modules to see if the issue goes away.

So I guess I will go ahead and swap a Y axis module (I already traded one of them recently because it was faulty, thats why I ordered spares) and then see if the issue persists. it would be really nice to nail it down in that one move, because otherwise this is going to be an awful lot of trial and error…

I’d hate to trade both y modules, as one is brand new, but id also hate to waste the time on it and have it come out bad because the new one is funny or something… sigh, no matter what i do this is going to be a pain in the ass.

After i trade modules i will run the exact gcode, then if i still see issue i will maybe try the slowed down feed rate from the controller

Well, to provide an update…

As support suggested I swapped the 2nd linear module on the Y axis (the first one i had already traded out due to an issue) because I have spares.

This proved to be a fruitful move, as the part made it through the print.

a bit stringy yeah, tried it with some more silk pla because the pantone green pla i purchased and opened was wet out of the bag :expressionless:



I had updated edwin that the print was successful after trading a y rail.

I asked him if i could exchange it for a new one and he said no i already have 3 new rails.

I purchased two of them and one was from a failure, replacement.

I am getting pretty peeved. He says the second original Y should work for X axis, but here is the original x axis doing the same thing, so I am to believe that i can use that one?

So now I have 3 new rails I installed on the machine (two of which I paid for), 1 rail that doesnt work at all due to being so sloppy, two rails which skip steps, two more rails for Z axis bound to die any day now, and no spares left.

Right towards the end of a 7 hour print, which is a present for someone for christmas, and still have more gifts to finish due to having to constantly fight this damn machine.

I am ok with them having problems… as long as they back their product.

Their response that they aren’t giving me a traded rail on the Y and to use it for X, then immediately after have X do the same thing, done pissed me off.

Same story, sheet is where it belongs on the bed. no evidence it shifted.

Time to go back thru all the footage again and try to pinpoint the “event”

They only answer about 1/3 of my emails to them anyhow, so who knows if they will bother responding about this one…

Naturally i cant fit the gcode file so i have to go thru all the garbage file sharing again.

1 Like

I’m starting to get pretty frustrated with printing again.

The machine was running beautifully for a week or two and the past day or so I have been fiddling around with some new gapping that was exceeding previous by alot, enough that the shell isnt connected to the infill.

I had my flow rate set pretty low before, because the flow rate test caluclator said thats where it needed to be, and i must say it really was putting out some great parts.

with that said, now I am running into the gapping i mentioned so I have been trying many things.

My flow rate is back to 100% now, fiddled with overlap a bit (immediate overextrusion, nozzle was getting coated in filament), fiddled with z offset a bit to bring it closer (not much change either way), fiddled with temperature a bit (not much change either way), and finally i at least was able to get one of my swatches that wasn’t falling apart (still isn’t very perfect but it will have to do).

I have successfuly printed these swatches 20 times now. I was having no luck with some PETG garbage (overture brand has to be the 2nd worse filament on earth, next to snapmaker) i had so i went back to matterhackers PLA and i still cant print it

Did the bullshit snapmaker filament (not the spool in the box, the extra spool that support promised me was safe to use) that clogged my shit up permanently fuck up my microswiss nozzle? i dont see how that could be the case, its clean as a whistle, but god damnit everything was fine til i loaded that bullshit up.

So now I was like hmm i want to see a calibration cube now to see how it comes out.

I am so irritated with the results.

first of all, if yet another linear module is beginning to lose steps i am going to be seriously pissed off. i already swapped out three of them, two of them i purchased for spares when i was waiting for them to issue my first one.

support didnt want to give me replacements for the two spares i ordered “they need to do some testing” and that “i already have three new modules” and that i can just use the layer shifting one on a different axis (except then it became 2 and they stopped talking about it)

Additionally, despite all of the fiddling above, why the hell is this gap here under the Z? its driving me CRAZY

Im already pushing the limits of extrusion, any more and i know its oging to start dragging (if it didnt already causing that line) so I dont know what else I can do!

one step forward, 27 steps back - and im about to walk away from this damn thing.

i did do estep calibration, and confirmed it was valid 2 days ago still.

i guess i could stand to do the k-factor test again.

i just want to reprint my fucking fan adaptor that came out like shit because the machine’s cooling sucked too much when i printed it and it looks like shit so i wanted to replace it.

The z gap looks like a slicer issue, if you’re using simplify 3D make sure you have thin wall mode enabled.
I usually use thin extrusion mode, think it looks cleaner than gap fill: https://www.simplify3d.com/support/print-quality-troubleshooting/gaps-in-thin-walls/

That was one of the things i changed this morning trying to fix the problem! i thought “hmm gap fill… maybe it will fill these gaps”

I will put it back though.

maybe i can solve at least one part of this thing, ill try it now.

also put the percentage back to 10 i moved it to 15 in a second attempt to fiddle with it another time too.

those cube edges are so terrible. its disgraceful.

What’s your preview look like. I just sliced with a setting I was guessing matched yours and there’s clearly a gap:
Gap fill fixed the one side, but the other will still have a gap.

The way I solve that is changing perimeters:

My current go,

looks filled in to me, just a different line.

What did u change on the perimeter, made it 3 instead of 4?

i always use 5 perimeter, but ill try anything i guess at this point. i have all my swatches and none of them have this gapping until the past couple

i will definately try it tho im gettin real upset, thats the difference tho right less perimeters or did you do something else

Yea that was 3 instead of 4. That thin gap fill is suspiciously thin, it could work, but might not.

REGARDLESS you’re getting underextrusion, you gotta figure out why. Try upping infill overlap. Here’s my standard settings, see how it goes for you:
xyzCalibration_cube.gcode (352.3 KB)

ok, i will do some fiddling and get some pictures together. thank you brent as always

Why is your cube green and mine is blue? the (not easy to use) color chart is calling yours solid layer and mine external single extrusion i think? or is it outer perimeter?

If you prefer blue, here:

I was coloring by movement speed originally.


haha ok its fine i just thought maybe something was wrong and it was assigning things differently.

just kind of an “as i go update”

printed the cube with same parameters as before, except for swapping out gap fill for single extrusion and making the percentage 10 instead of 15.

This time I had no phantom line

Interesting side note: the Z gap is still present, however it is on a different face. Before it was pointing at the X side of the cube, now it is pointing the opposite way.

On to print the brentcube next, then i will start playing with more parameters.

it seems the brent cube is set to print at a faster pace than my cube was, i guess that is probably from the extra perimeters i had? running 5% infill currently, altho it was bumped back from 15% the previous cube, and the majority of my failures today were 100% infill.

brent cube is closer to my comfort level of 205, i was on 210 trying to get some better fusion going on.

update on brentcube:

a little surprised to see how little priming you do compared to what i need to do.

the skirt didnt survive at all (usually the first inch or so typically does not) and got janked up under the cube, and the cube is pretty poor in the bottom front left corner which looks like warping but i think its just adhesion related from the lesser priming (i skirt at least 8 lines to make triple sure its going to work because nothing sticks at first, but after its flowing well it usually comes out nicely and has good adhesion)

if you can print this cube with this priming method id really like to sit down and figure out what the heck and re-evaluate everything i do from the ground up. i thought i was starting to get pretty good at this but i guess not and i am just good at overcoming something while not even realizing other issues it causes.

with that said, im about halfway through it now.

i also need to sit down and figure out how to get rid of that little butt kiss at the end of my prints. i thought i solved it earlier with a small wipe movement but its back again.

Yes, with that code only the first inch of skirt is missing.

But at the end of the print there’s not much retraction either. Only has to make up 1mm.

1 Like