Device not detected over wifi from Luban

Just finished setting up the Snapmaker 2.0 and cannot get Luban to detect it over wifi. The touchscreen shows that it is connected to my network and I am able to ping the IP address from my desktop.

If I connect both the Snapmaker and my PC to a hotspot from my phone, Luban is able to detect the device. This smells to me like a router setting that needs to be tweaked, but I can’t figure out what to change.

Any suggestions?

Luban version 3.5.0
Firmware version Snapmaker2_V1.8.0.0_20200507
Touchscreen version V1.8.0.0
Controller version V1.8.0.0

It would be nice if you do a bit forum surfing.
There are a lots of threads.

The last one I have seen was because of a static ip adress, you should also check if it’s in the same subnetmask.
Also check your firewall, install the latest luban and restart your pc.
Hope this helps!

Hi Chris. Sorry, I should have mentioned these things. I looked at all the posts mentioning wifi on the forum. My PC is set to DHCP. I restarted both my PC and the snapmaker after installing the latest stable firmware/software.

Just to add to this:
My PC and the snapmaker are on the same subnet. SM is currently at 192.168.1.73 and my PC is at 192.168.1.36. I am able to ping the SM from my PC.

If I watch the network on wireshark, I don’t see anything coming from 192.168.1.73 unless I ping it. Should the SM be broadcasting something?

I tried turning Windows Defender Firewall off. As expected (because of the hotspot test), that made no difference. I currently don’t have any firewall rules set up on my router.

I’ve tried changing these router settings with no success:
-Enabled RIP-1, RIP-2B, and RIP-2M
-Enabled UPnP
-Open NAT filtering
-Reserving an IP address for the SM

push @parachvte, any ideas about @wheems prob?
Which router do you use @wheems ?

I’m using a Netgear R6700v2

I had the issue with not detecting of the printer when I used pi-hole as dns server. So then I switched back to my domain controller and it was available again.

For me it looks like as a resolving and registering issue with dns/dhcp but not troubleshooted further down. Or if you have any settings done in the wifi which is blocking communication between lan and wifi. There are also settings in some devices which prevents communication between wifi clients.

Actually not at home to do a try with switchback to help you further at the moment.

Hope this helps for the first digging in the direction…:wink:

Ugh. This would be so easy if I could just put the IP address into Luban myself. Is it looking for some sort of broadcast from the Snapmaker?

When I use wireshark to monitor the network, I am not seeing anything from the SM until I send it a ping or API request.

I know that I have communication both ways between the Snapmaker and my PC because I get responses from pings. I am also able to post to http://<IP_ADDRESS>:8080/api/v1/connect and I get a response with token, readonly, series, headType, and hasEnclosure values. After sending the connect command, the touchscreen shows that there is a wifi connection request.

Feature request submitted.

2 Likes

Luban sends a boardcast to like 192.168.1.255, and TouchScreen responses so Luban knowns the IP address. You can check on Wireshark if a broadcast was sent.

1 Like

We may be getting somewhere now. I don’t see anything coming from Luban when monitoring my WiFi interface. But when I monitor my “Adapter for loopback traffic capture” interface, I see the discover messages going out every time I hit ‘Refresh’ on the WiFi connection in Luban. Is Luban just not using the right adapter?

1 Like

Seems like the the packet was sent from 192.168.1.20 and the response should go back to it. (not loopback)

Hey,

I have the same issue. My device is not detected by Luban. It first appears after some minutes of trying and for some reason it then gets added multiple time to my list.

I did some tests with wireshark, too. The UDP broadcast is sent from Luban correctly. But my machine is first responding after like 1 minute of hitting refreshing.

In the image above you can see me hitting refresh all the time (for like 90 seconds). Then after 89 seconds the machine is first responding, even though it was running all the time for multiple minutes and it was always connected to the internet.

But even though it responded, it does not get updated in Luban. There is still no device in my list. I then have to continue hitting refresh for like 3 more minutes until finally it appears in my list. The fun thing is now that my device is appearing multiple times in my list.

[SEE IMAGE IN NEXT POST]

The message selected and marked with the arrow is the one which made my device finally show up in Luban multiple times. Could you snapmaker guys please try to help me with this? It is super annoying. I already contacted the support. Tracy is trying to help me right now. But this issue might be connected with the one of the others.

Here is the image missing in my previous post (New users only allowed to post one image per post)

1 Like

I had the same problem… I detected the Snapmaker 2.0 in the routers device list and set its IP to static using the MAC address. Luban would still not recognize it although i manually added the IP showing both on the router and confirming on the Snapmakers “about info”. The connection in Luban would time out…
I tried to ping the machine just through cmd and after getting a reply i tried to connect Luban again… and it worked magically…

That sounds to me like an ARP cache issue on the workstation running Luban.

1 Like

This! This was my issue. And it turned out to be as simple as restarting my gateway/router to clear up the ARP table in the router, and then, again on my workstation. (Didn’t help to just restart the workstation, because it just asked again for the same corrupted ARP entry from the router.)
Thanks, @ITmaze, for the hint!

1 Like

I ended up connecting my workstation to a hardline instead of WiFi and then was able to detect the Snapmaker device. Haven’t looked back since.

My workstation (OSX) can sometimes find and connect to the Snapmaker ok, and sometimes not.
Currently it’s broken again, and in terminal, sudo arp -a shows:
android-cb57a3fd1e1acd48 (192.168.50.3) at (incomplete) on en0 ifscope [ethernet]

All the rest of the devices listed show the mac address. So I assume this (incomplete) status for the snapmaker is the issue.

I tried resetting the arp cache: sudo arp -a -d
And restarting my router.
And disconnecting my OSX and the Snapmaker from wifi and reconnecting.
And setting static IP for the Snapmaker (assuming that if the ip address doesn’t rotate that things will work better generally?)
and pinging the Snapmaker IP address.

Still, the arp table shows (incomplete) for the Snapmaker.

After deleting the arp cache, it shows missing. And then pinging it brings it back, but with (incomplete).

So, I tried setting it manually:
sudo arp -s android-cb57a3fd1e1acd48 54:65:03:00:8C:1B

This helped in that a ping is able to find the snapmaker properly now, and get back 64 bytes instead of a “request timeout.” Still, Luban does not discover the device on the network.

If I ping 192.168.50.255 I get back plenty of device responses, but nothing from the snapmaker at the .3 address.

I’m going to try restarting my workstation next. Any other ideas out there let me know!