Luban 4.7 "Something went wrong. Please reload the app"

Updated to Luban 4.7.0 and now I get this message at startup:
“Something went wrong. Please reload the app”

I’m on Windows 10. I had not upgraded since 4.4 because Luban has always been problematic with every upgrade. I have tried uninstalling and reinstalling the app with the same result.

Any suggestions on resolving this issue would be appreciated.

1 Like

Maybe deleting the app folder helps

1 Like

That fixed it! Thanks!!

This “Something went wrong …” message is that still a bug? I updated Luban on my portable to version 4.1.10. Windows 11. Tried to update a few apps, made sure last version Windows was installed cleaned cookies and a few other things. Same result. Went to my desktop (windows 10) and updated to last version. Same result. Did some cleaning, updating and installed version 4.9.0 same message showed up. Seemed to happen when I went from edit mode to process mode.

Installed the last functioning version on my computer which was 4.3.1 and the message disappeared.

Is the only solution still to delete the Roaming folder for AppData?

Any suggestions on where to find that file on MacOS?

A more precise solution here:

1 Like

I found a hidden file named snapmaker-luban.json in my home directory. I deleted it and reinstalled the Snapmaker Luban software but I still see the error screen that says there was a problem, please restart the app when I try to create a tool path.