Luban 3.9 Laser Cutting - Missing Lines

I am trying to create G-Code files to cut basic shapes. Regardless of whether I add them as dxf or svg Luban misses some of the lines, this is not consistent as it seems to depend on whether I place the image as to which lines are missed. What is going on? The files come from either Inkscape or Freecad - same issues with both.
Is this me? the Luban or the Freecad/Inkscape?
Thanks

You have to share settings (screen captures) and files for us to be able to help.
-S

This is the G-code

That’s the file after I click process

And this is the original file after import

Thanks a lot for the reply

Have you tried running this?
Or are you just going by how it looks on workspace?

Need to post your files so we can check them.

-S

Not yet as I keep having the problem. I can’t post the file - I don’t understand why though

Here are the files.

Thanks for the help

(Attachment FishPowerBoxb.dxf is missing)

(Attachment FishPowerBoxend.svg is missing)

Not seeing the files.
I think there may be a restriction on uploading for new members.

If you haven’t tried running it, I would use a scrap piece to test. It’s a quick file to cut.
The console preview is showing tool paths so it’s really hard to tell what it’s actually doing sometimes.
-S

Good_Perkin, there are not missing lines.

In workspace you can see two types of lines: in dark the lines that are going to be cut and in light grey the lines indicating were the laser module is going to move thought. The problem is that the latter overlaps the firsts. But if you run the cuts, you will fine that everything is correct.