Luban 3.5.0 Not sliceing

Hi,

I just downloaded the latest Luban, and it is not able to slice. I’m using it on a linux system, and I launched it from the terminal. I load my stl, then choose my settings, and click on slice – it hangs at 0.0%. When I refer back to the terminal, I see these errors:

2020-06-17T15:54:17.205Z - error uncaughtException: spawn EACCES Error: spawn EACCES at _errnoException (util.js:1024:11) at ChildProcess.spawn (internal/child_process.js:323:11) at Object.exports.spawn (child_process.js:514:9) at so (/opt/snapmaker-luban-3.5.0-linux-x64/resources/app/server/index.js:1:248084) at uo (/opt/snapmaker-luban-3.5.0-linux-x64/resources/app/server/index.js:1:250267) at Socket.<anonymous> (/opt/snapmaker-luban-3.5.0-linux-x64/resources/app/server/index.js:1:31534) at emitOne (events.js:116:13) at Socket.emit (events.js:211:7) at /opt/snapmaker-luban-3.5.0-linux-x64/resources/app/node_modules/socket.io/lib/socket.js:528:12 at _combinedTickCallback (internal/process/next_tick.js:131:7) at process._tickCallback (internal/process/next_tick.js:180:9) 2020-06-17T15:54:17.207Z - error: uncaughtException: spawn EACCES date=Wed Jun 17 2020 11:54:17 GMT-0400 (EDT), pid=26048, uid=1000, gid=1000, cwd=/opt/snapmaker-luban-3.5.0-linux-x64/resources/app/server, execPath=/opt/snapmaker-luban-3.5.0-linux-x64/snapmaker-luban, version=v8.9.3, argv=[/opt/snapmaker-luban-3.5.0-linux-x64/snapmaker-luban], rss=185081856, heapTotal=58822656, heapUsed=51845800, external=812748, loadavg=[1.05859375, 1.14013671875, 1.10693359375], uptime=450072, trace=[column=11, file=util.js, function=_errnoException, line=1024, method=null, native=false, column=11, file=internal/child_process.js, function=ChildProcess.spawn, line=323, method=spawn, native=false, column=9, file=child_process.js, function=Object.exports.spawn, line=514, method=spawn, native=false, column=248084, file=/opt/snapmaker-luban-3.5.0-linux-x64/resources/app/server/index.js, function=so, line=1, method=null, native=false, column=250267, file=/opt/snapmaker-luban-3.5.0-linux-x64/resources/app/server/index.js, function=uo, line=1, method=null, native=false, column=31534, file=/opt/snapmaker-luban-3.5.0-linux-x64/resources/app/server/index.js, function=null, line=1, method=null, native=false, column=13, file=events.js, function=emitOne, line=116, method=null, native=false, column=7, file=events.js, function=Socket.emit, line=211, method=emit, native=false, column=12, file=/opt/snapmaker-luban-3.5.0-linux-x64/resources/app/node_modules/socket.io/lib/socket.js, function=null, line=528, method=null, native=false, column=7, file=internal/process/next_tick.js, function=_combinedTickCallback, line=131, method=null, native=false, column=9, file=internal/process/next_tick.js, function=process._tickCallback, line=180, method=_tickCallback, native=false], stack=[Error: spawn EACCES, at _errnoException (util.js:1024:11), at ChildProcess.spawn (internal/child_process.js:323:11), at Object.exports.spawn (child_process.js:514:9), at so (/opt/snapmaker-luban-3.5.0-linux-x64/resources/app/server/index.js:1:248084), at uo (/opt/snapmaker-luban-3.5.0-linux-x64/resources/app/server/index.js:1:250267), at Socket.<anonymous> (/opt/snapmaker-luban-3.5.0-linux-x64/resources/app/server/index.js:1:31534), at emitOne (events.js:116:13), at Socket.emit (events.js:211:7), at /opt/snapmaker-luban-3.5.0-linux-x64/resources/app/node_modules/socket.io/lib/socket.js:528:12, at _combinedTickCallback (internal/process/next_tick.js:131:7), at process._tickCallback (internal/process/next_tick.js:180:9)]

I noticed that, in the tarball, none of the executables were set to 755 perms, Obviously snapmaker-luban requires this, but I don’t know about anything else in there… perhaps that is the source of my problems? Maybe it is completely unrelated. Anyway, it isn’t working…

Thank you.

-mg

Well, that was indeed the problem… the perms were not set properly on ./resources/app/resources/CuraEngine/3.6/Linux/CuraEngine

Setting them to 755 did the trick!

So, going to the top level of the Luban directory (I put mine in /opt/luban) execute something like this, and it will fix it:

chmod 755 snapmaker-luban ./resources/app/resources/CuraEngine/3.6/Linux/CuraEngine

-mg

I have exactly the problem but in Windows version.
It was working and then this morning Windows did an update and nbowl its not working in the moddle of my class can anyone help with a simple solution before the students riot

Thanks

“Executability” is a function of the extension in windows, rather than a permission (as is the case on a *nix system). It has to be something a little different.

Last week’s patch tuesday rolled out an update that screwed up printing (for regular 2d printers). This Monday, they released a patch via windows update that fixes it. It is possible that this may have affected your system in some similar way. Have you tried going to settings > Updates and checking for new updates? Let it apply, then reboot,then give it a whirl. If it still isn’t happy, you can also check your application event logs to see what the application is complaining about. Hopefully, it does logging.