Laser "slipping"

I cannot figure out what is going on either my 350. When I use the laser it almost slips but the material is not moving at all. I just had to replace one of the Z axis Legs and the Controller to get it to even work I’ve had my snapmaker for less than 2 months and have not had any luck to get it to work right.

Sorry, I’m not sure what you’re describing.

Clearly the material moved in the picture you posted, so I’m not sure about that. Are you talking about the image being distorted or not centered? Is this related to camera calibration at all?

Also, there appears to be a gremlin under your table.

So that’s the thing the material did not move. I’ve tried several other things and its all the same I’ve got the martial taped down very securely and they’ll turn out thisnway. And I posted it then realized my daughter was in the pic haha.

And you don’t have this problem with 3D printing or CNC? You are generating all your gcode with Luban?

I have not tried the cnc part yet and I was only able to make 1 thing with the 3d print before the Controller completely broke. I am using luban to generate the g code

So are your 3d prints skewed in the same way?

I was only able to make one print before the entire thing broke. Its turned out alright but it looks like it moved a little between a couple layers.

So nothing at all works right now? I was under the impression you replaced things and had a “working” system and the skewed laser was your only problem?

If that’s not the case, contact support.

Other than that, you are giving very little information for anyone to be able to help you right now. When contacting support I can only recommend you to be as detailed as possible.

And 3d model isn’t great either. Something went wrong. Are you sure you assembled the machine correctly?

No it works now. Sorry for the confusion. I recieved the the new controler yesterday. I have reached out to support again to help me but figured I would try other avenues as well to see if anyone had a simular issue. I’m not sure how much more specific I can be. Laser will not do the job right. It gets Almost half way though any project I do then the design starts to almost slant as if the item being engraved is moving but it is not.

OK, that’s clear now.
So have you tried a print since you replaced the controller? If yes, do you see the same problem? If no, please try and see how that looks.

Have you done a firmware update (from USB stick) with the new controller to make sure you are on the latest firmware?
(maybe try this first anyway)

Sorry for all the confusion I really appreciate your help
Yes I have tried 2 priject both messed up currently working on my 3rd laser project. First thing I did was check to make sure my stuff was updated via wifi but I will try the USB.

Just to be sure. Are you sure you assembled everything correctly?
Can you post pictures that show the complete machine, front & side? just to double check. A lot of people have been making mistakes in the past.

I’m putting money on your controller being bad. Contact support, I’ve seen this happen a lot lately and each time it’s the corresponding axis port on the controller being bad.

That was the orginall issue I just got my replacemnt controller in on Saturday so hopefully I did not get 2 bads ones.




I really hope it’s just something like I installed something wrong. However I think I did everything correct.

I mean, unrelated to your other problem, you do have the Y linear module installed wrong.

They should be centered on the base. Not hanging over the edge.

-S

It’s almost like the groves in the base plate are meant for the whole rail🤦‍♂️ I’m an idiot haha I’ll make the change later I wonder if that might solve some of the issue thank you

You’re not the first, and won’t be the last probably.

Maybe, just maybe this caused some tension on the modules and/or the mounting of the bed somehow making it to skip steps in the weirdest way causing your problem. Let’s hope this solves it for you.

At the least it will give the bed level calibration and focus efforts of the laser module a chance to actually work :wink:

Fair point thanks yall I jist.made the changes and I’m gonna test it out later