Laser cut not in sync with movement (starts cutting late)

I tried cutting paper but some lines were randomly not cut. I formed the theory that the reason could be, that the cutting starts too late in some cases, when the movement speed is high (I did the cutting with 650mm/s when noticing this - at 700mm/s it gets worse).

So I created a test svg in Inkscape and in deed, it turns out that in some cases, the laser is firing up late, causing cuts to be incomplete, see this photograph of my test here:

As said, settings were 650mm/s, no repetition of the cuts. Since the delays show up at random, repetition makes the problem go away, which is however not how I would like to see this solved.

I’m pretty sure that this is a bug.


Here’s the SVG to reproduce the issue. As a new user, I couldn’t add it to the original post.


Do you have an enclosure? It could potentially be a faulty door closed sensor. If the sensor isnt triggered (i.e. door is open) it reduces the laser power so that nothing can be cut. If the sensor is faulty and intermittently showing as open then it could cause this?

If you want to test this, you can deactivate the door open sensor. I think this can be found either on the touchscreen menu or in Luban settings.

1 Like

Interesting idea. Tried it again with deactivated door sensor, this time with 700mm/s - which amplified the problem a great deal (yay for reproducing). Also, if it had been the sensor, it wouldn’t appear only on starting points:

Btw, I am using Luban 3.9.0 using WiFi / USB options.

1 Like

Hmm, if it was simply an out of sync movement start and laser power up I would expect the un-cut portions to be fairly equal but your image shows significant variation. I wonder what could be causing this…

out of curiosity how were you controlling the laser, via a PC USB connection or via a USB memory stick?

It would be extremely helpful if you could do the identical file in three ways:

Via wifi, via USB cable and via USB stick.

Same identical settings for each.



Is it doing the same thing with identical settings? If you do the test multiple times with the same g-code does it have the same results?
If it’s doing the same thing it’s a software/g-code problem.

If it’s random it’s an intermittent hardware problem - door sensor, laser cable, controller, head.

If it’s software, I’d suggest trying the same thing with 3.8.
Just to make sure the version of Luban isn’t buggy.

On the v1, it isn’t recommended to do laser or cnc via the USB cable. Micro pauses on the host computer translate to speckling on the image as the laser dwells just a bit too long or starts a bit too late. CNC is less obvious because the movements are slower, but it does have the same type of issues. The USB drive gives much better results for both.

I don’t have a v2, so I don’t know if wifi transfers the file to the controller, or streams the commands in real time.

the v2 can do both options - you can transfer to the controller and run locally (what I do for no particular reason, just seems better to me with power loss recovery, etc), or you can stream gcode from Luban (seems to be required if you use Camera Capture to set the work origin)

I was doing some testing with the calibration pattern in paper, is this related?