Laser cooling fan turns off prematurelyduring cutting

Hi has anybody noticed the following problem:

I wanted a lasercut square using 3 mm plywood and Luban.
Settings 500mm/min and 100% power and 7 passes.
Printing starts fine with the fan going strong.
After one round of cutting the fan shuts off and the laser carries on cutting merrily and smoke starts coming out of the module.
To check I opened the side panel and can see the fan shutting down.
Tried the same using Lightburn and the results are the same.
Opened the gcode and removed the M107 ( turn fan off ) command which resulted in the fan NOT switching off until the cutting was done.
Wierd behavior.

Hi, what is the firmware version? You can find it by tapping on Settings > About Machine on the touchscreen.
The latest firmware is v1.12.1, you may install this version to have a try if it is not the latest firmware on your printer. You can get it from the following link:Snapmaker 2.0 Firmware Updates and Downloads
Please share a video of the problem if possible. Thanks.

Hi Potter,
Firmware version is the latest v1.12.1.
To duplicate the problem, draw a 5 cm square in Luban, set the amount of cuts to 7 or so.
After the first or second round of cutting the laser is still on but the fan has been switched off.
It seems that the M107 command is executed immediately when encountered in the gcode file.
As said, after removing the M107 command the laser cut is done properly with the fan on until the project is done.
Hope this informs you better about the problem. Take care.

Another simple solution is to add a multiple small square cut as the last to be cut.
This also ensures the fan is on until done.

Hi, sorry for the late reply. I’ll make some tests and try if the problem could be recreated.