Laser camera issues

Just got my 250 set up last weekend. Seems like every time I try to do the camera capture and have my work surface centered that the object ends up getting put way up in the right hand corner of the bed. I deliberately put it in the center of what the camera captured but still ends up trying to run way up and to the right. Isn’t this the point of camera capture? What am I doing wrong?

I don’t remember where the link is to the official instructions are, but this happens when 1 or more of the instructions are not followed exactly. Go back to the instructions that you are following, and make sure that you are following every single one exactly as written. No substitutions.

Set the work origin to 0,0 at the front left of the bed before starting the job. An annoying ‘quirk’.

So while entering the dimensions of the project piece? Instead of center do front left?

I moved the picture to the top right of the workspace before I processed the g-code. Still moves here and I don’t know how to change it or verify its going to print where it says.

I see, you mean in Luban? I thought you were talking about when you run the job.

Is the size of Snapmaker set correctly?

Are you following the directions here:

I believe so but I can’t honestly say that I checked. I’ll look when I get home to verify. I guess it would make sense though because last night it was trying to engrave off the bed.

Which version of Luban are you using?

I’ve not used the laser for a while so I though I would set it up again to try to figure out what’s happening.

Since the last time, I’ve updated to Luban 4.01 and it looks like all the issues (which the staff said weren’t issues) with the origin have been fixed. I’ve tried various positions on the bed for the job and running the boundary has been perfect for all. I can’t believe it, been asking for this for months and months!

This is going to seem like an awfully stupid question but, how do I verify the machine i.e… 250 or 350?

If you go to Settings - Machine Settings - Machine Settings you can see what has been detected or if not connected set the size of machine manually.

I’ve done a bit more research, things are not fully fixed. I found that if I used the camera to capture whatever was on the bed, arrange the objects aligned with the image that the problem was just the same, the work origin was in the centre of the bed. So I opened the Job Setup menu and saw the options were greyed out. After a minute head scratching I turned off Background in Camera Capture, tried again and the origin was correct! I ran the job and it was almost good, out by 10-12mm.

I’ll have another go with a bit more care. Looks like there are still issues but might be nearer to a workflow which doesn’t mean jogging the head to the front left of the ben anymore. Hurrah!

Great job! I found that my machine was recognized as a 250. I looked to make sure that the machine is up to date and its not. Still running V1.8.0.0. Unfortunately there is no place to select to update.

A bit of topic but…
Just used the 3D head for the first time and yes I followed ALL directions but now it won’t save the setting it asks me to find and the first time it did “save” it tore the print surface apart. Huge grooves going down the bed.

To update from v1.9 and before you need to load the firmware on a usb drive.
Wifi firmware update was introduced in v1.10.


Dang nabbit. Now that you say that I remember reading it at one point. Thank you.

That is a known issue with firmware v1.8 and earlier. Since we were only discussing the camera offset of the Laser Module, this was not discussed. This is something that @Melitta_Snapmaker needs to figure out, as:

  • New units should be shipping out with the latest firmware release (v1.13.2 as of the time of this post).
  • Existing users are not aware that they need to update their firmware before doing anything at all with their machines.

@Melitta_Snapmaker needs to inform all existing owners that they need to upgrade to 1.13.2, perform a factory reset of both the Controller and the Touch Pad, then upgrade to 1.13.2 again. If you have custom settings, you need to print them out prior to the upgrade, and then re-enter them after the upgrade. They can’t create a firmware fix that will automatically do this, as it would cause issues with new owners who did follow all of the directions.

Thank you! That was exactly what my thought process was. I ended up updating the printer head this morning and now it is printing but my bed is magnetic surface is wrecked from the process.

@rckt_rcn you can flip over the build plate, as it is double sided. It sucks that you had to find out the hard way, but that is on Snapmaker, not you.

True but, unfortunately I had flipped it and tried again after I thought I had leveled the bed but before I had updated. I was wrong.

Ok. Ive updated every module. After updating this morning, I had the 3D printer working although not too well. Now it will not recognize while I am trying to level and it prints like absolute sh*^. Why is this SO HARD?