Laser Autofocus Failure - No Laser Beam

Trying to set up to do my first laser engraving, but when I go through the calibration procedure that appears the first time I use the laser I get to the point where it’s supposed to engrave a set of lines on the material and the beam is so dim, so low powered, that it can’t engrave anything on the material. There’s no power adjustment during any of the previous screens to turn up the power, and trying to swipe left to bring up the control settings isn’t available yet.
Suggestions? I watched the beginner videos in the e-mail Snapmaker sent out to users today but the one on using the laser was no help with this issue.

2 Likes

Perhaps an idea to stick a thin piece of paper on the material?

The paper will burn lines for sure

do you use the snapmaker enclosure? Than close the door :wink:

it’s a known issue.

2 Likes

Door open, door closed. Makes no difference.

Try it with enclosure being disconnected… I had the same problem and by testing this I found out that the door sensors had to be readjusted

Something similar happened to me. How far is the laser from the surface? The laser hood should be more or less 4 mm from the surface of the material. Otherwhise force it manually at about 22mm from interface and the perform the autocalibration again.

i assume you use luban to run the job. Be sure to set power in the workplace by clicking the arrow behind it, that will send the code to the machine.

The controls on the screen wont work when running a job through luban. Luban 3.8 also has enclosure controls, another user couldn’t find these until he maxed his window.

Good luck

The calibration procedure is run when the laser head is first mounted on the machine, before I ever get to the point of loading Luban on the other computer and generating a project. Everything in the calibration procedure is done from the touchpad, and I’m locked out of the menus until the calibration is completed. It doesn’t allow me to set laser power before it tries to do the Autofocus part of the calibration. So whatever setting the system boots up in for laser power is what is being used there, and it’s too low power to engrave anything.

1 Like

That sucks man, it should have the proper laser power, no doubt. Are you using paper for calibrating? Maybe you can download an example of the ruler it creates and put that on the bed during the calibration to fool the machine? Just a thought.

Its likely due to a faulty door closed switch. Have you tried @ml1140 suggestion of disconnecting the enclosure and running the autofocus again?

If the switch is faulty and thinks the door is open, as part of a safety feature the SM2.0 will limit its laser power such that nothing can be cut or engraved.

Did you start in 3D print mode, then switch to laser more recently? I had similar confusion, and I think part of the issue is their enclosure sensor setting on/off is kind of a dumb toggle and between the machine and Luban it gets confused. Bear with me.

In 3D print mode I left enclosure door sensor off (using touchscreen interface). But then I’d notice that Luban if I connected would show it as on. Click the button on Luban to turn it ‘off’ then disconnect, check machine, it thought it was ‘on’. Like the Luban was just a toggle with a starting state in the SW that had nothing to do with reality. Ditto with light and vent fan, what the Luban button said wasn’t what sate it was visibly in. [Or am I confused and the labels are meant to say “if you click me you are setting this labeled state” not “i am an indication of the present state?” But I’m pretty sure by shuffling back and forth I could get either “ON” or “OFF” showing while the light was “ON”.] Regardless, I made sure at the touchscreen it thought the enclosure door sensor was ON, before I powered off to swap to the laser head.

Like you say, it rolls thru a first time calibration on the touchscreen and doesn’t allow you to do anything but follow along for that first line engrave, but for me the laser did work. Then when I do actual lasering because their instructions aren’t as good, I’ve been importing and laying things out, setting power and # of traces in Luban and finally pushing over the file to the machine via wifi connection. Same thing I mentioned before about light, enclosure vent fan, and door sensor toggles in Luban all being sometimes opposite of the ‘real’ state.

I can even jog and locate my desired start point, ‘save’ it, run boundaries, then push the file across Wifi (which then tells you to move over to the touchscreen to actually confirm running it) and it makes me go thru re-setting the start point all over again. The SW here clearly needs a lot of workflow re-think (or I’m just dumb, who knows).

Bottom line - there’s a chance youre in an “off” state for the enclosure sensor and can’t fix it. Maybe try swapping back to the 3D print head, see if that lets you see, then swap back over. Pain I know but only suggestion I’ve got (outside of others suggesting to just disconnect the enclosure entirely which to me is slightly eyeball risky…)

OK, with the enclosure unplugged the Autofocus did work as expected
based on the videos. So how do I get the door switch aligned correctly?
I can’t shut down the system to plug the enclosure back in because then
I have to through the Calibration procedure all over again on the
reboot. And they advise strongly against unplugging and plugging in any
of the cables while the system is powered.
Another thing that bugs me about this Autofocus procedure is the
waste of material. After it draws the lines during Autofocus that
material has to be discarded and fresh material put in for the real work
piece. Right now I’m just using scrap plywood while I tweak settings to
get the result I’m hoping for, but over time this can lead to a lot of
material discarded just to run the Autofocus every time the system is
turned on. I imagine it’s going to be similar for the CNC as well as 3D.

1 Like

I’m not sure if you have to redo the focus process every time. As I understand it, only after you change modules.

My experience so far is that every time I’ve turned on the power with
the laser head mounted it takes me into the calibration procedure with
no option to bypass it.

1 Like

It shouldn’t.
Once the laser is focused it should be set. It measures the focus of the laser optics not the bed height, so it stays the same even if changing between heads.
The only reason to redo it is if a firmware update changes it.
What firmware are you using? I was having a bunch of weird issues with 1.10.1. Nothing I could consistently recreate. One of them was related to laser calibration, so I went back to 1.10.0. (some people suggest 1.9, but the only problem I’ve had with 1.10.0 is the 99% finishing error)
-S

Hi @RickJones

  • Do you use the enclosure? Can you please close the enclosure’s doors well first during the auto-calibration?
    If the doors are open during auto-calibration, there will be no lines. Or you can go to enclosure>settings where you can disable door detection. Then you can open the doors during the auto-calibration.

  • As you can see in the picture below, can you control the laser engraving module via the touchscreen?

  • How about the 3D printing module and the CNC carving module? Can these two modules work normally?

  • You can use the converter cable(8 pin) to test the laser engraving module.

[Edwin] Edwin https://forum.snapmaker.com/u/edwin Staff
September 19

Do you use the enclosure? My first attempts at Autofocus were with the enclosure, and I encountered the failure documented in this thread. After other commenters suggested unplugging the enclosure I tried that and the Autofocus worked as shown in the videos. Unfortunately, engraving on any material without the exhaust fan running leaves odors in the house and is therefore not the preferred why to do it.

Can you please close the enclosure’s doors
well first during the auto-calibration? Yes

If the doors are open during auto-calibration, there will be no
lines. Or you can go to enclosure>settings where you can disable
door detection. Then you can open the doors during the auto-calibration.
As you can see in the picture below, can you control the laser
engraving module via the touchscreen?

<https://global.discourse-cdn.com/standard10/uploads/snapmaker/original/2X/f/fa5b2ee679e14727a7a1e5e4f8083d2ecc84bb87.png>
Yes
How about the 3D printing module and the CNC carving module? Can
these two modules work normally?
I have run 2 test prints with the 3D head. It appears to work 

normally although I was a little disappointed with the results. I only
used default settings so that can probably be improved with more
knowledge. I have not yet tried the CNC tool head.

@Edwin I am seeing a similar issue. My first setup after building the machine was to install the laser module. It ran through the process with the laser working perfectly. Autofocus failed so I inputted the best line. The camera calibration square cut 3 sides. My demo box cut was great and I even placed a couple of images on two faces. Everything looked great. Even the camera calibration worked fine. Quite nice actually.
I then upgraded from FW 1.7.0 to 1.10.1 to take advantage of the enclosure lights. This is when thins went odd.
The next test laser engraving I went to do a camera capture and all came through except the last (9th) picture panel. Luban (3.9.0) froze up. After restrating everything I tried to go back through the laser cal and started seeing the same issue with the laser not being at a strong enough power to either make the autofocus lines nor the camera calibration square.
I down graded back to FW 1.7.0 thinking it was something in the FW but the same issues remain. I am able to use the laser for jobs but the calibration routines are not providing enough power to allow lines to be etched/cut.
I can turn the laser on through the settings but as soon as I leave that screen it turns off again.

Update: I reinstalled FW 1.10.1 and was able to do a successful auto focus and camera calibration. However, now the enclosure exhaust fan will not turn on. I’ll try another FW install to see if this is more of a firmware update issue.

If you run again into the same issue about low laser calibration, check if your doormagnets are in place.
There are several people reporting fallen off magnets, so the machine thinks the doors are open.