Issues changing filament

Hi,

I finished my first roll of filament this week. So I wanted to change it to a new roll. Which I was expecting to be really easy. But it turned out to be a disaster.

There are several things which went wrong during this process, which I will highlight here below.

The problems started with not being able to push through the new filament. I pressed the button and tried to put through the filament. Something I thought went very well at first. Cause I could insert it, and the filament disappeared into the module. But… It did not come out of the nozzle. Plus I heard something which sounded like the filament hitting a fan.

Obviously, I subtracted the filament back immediately. Then I opened the module to see what went wrong. Which brought me to the second problem. I noticed in a video which explains how the nozzle should be changed (https://www.youtube.com/watch?v=3dSHRMNjkGo), that I am missing some screws. The one at the bottom (next to the nozzle), and one which is in between the two outer screws of the heatsink. The wires cannot be pulled out which makes me think that the nozzle is cluttered with filament and that the wires are molten together with the PLA.

Can someone help me telling what to do? So I can change the filament and start printing again.

2 Likes

I opened the module and found the problem. I changed the filament without using the “change filament” setting. Which caused the motor from being able to push through the newly added filament.

I removed this filament with a plier. Re-assembled the module. And everything works appropriately. The screws I thought where missing are not. The one at the heath sink I was able to unscrew. The one next to the nozzle I could not unscrew with a 1.5 allen key.

Glad you fixed your problem :slight_smile:

I sometimes have an issue where the filament doesn’t run along perfectly and simply straightening out the filament and trying again works. I’d always recommend using the “Change Filament” option :slight_smile:

-Greg

and simply straightening out the filament and trying again works.

Sure, sounds easy. And Kepler’s Third Law of Planetary Motion is “The square of the orbital period of a planet is proportional to the cube of the semi-major axis of its orbit.”

See how easy that was? Changing Filaments on the Snapmaker and Rocket Science is just a matter of a few words.

I’m at the point I’d rather buy 7 3D Print modules just so I never have to Change Filament, I’ll just change Print Modules.

Hey!

What troubles are you having with changing filament? It took me a good 1000 hours to perfect it but I still get some hitches here and there haha :slight_smile:

-Greg

2 Likes

Hey all,

first I thought as well that there is a problem. However, Gregs advise to straighten the filament should be taken seriously :wink:

It is not the tip of the filament that makes the problem. Between the pipe outlet inside, the printing head, and the funnel intake of the heating unit is around 1,5 cm. The funnel is not really wide. So if over the 1,5 cm there is a slight bend of the filament & a slight bend within the pipe on top, it will hit the edge of the funnel and will not enter the heating unit.

So straighten out the filament for around 10 cm does the job perfectly! :smile:

I did not had the problem for the first two times and then I thought something is broken. :slight_smile: :wink:

KR Kai

2 Likes

I also cut the filament at 45 degrees. Gives you a pointed end which fits better.

2 Likes

Ok, my 2 cents. It seems changing filament is a skill you need to develop with Snapmaker. I learned that you have to straiten the filament, cutting filament at 45 degrees helps, but the big problem is the push button. Pressing to hard will block the filament. You have to feel the right position for the filament to go through. Hope this helps.

2 Likes

I have solved the physical problem if you can’t insert the new one when changing the filament.

When you insert the filament from the roll, it is usually bend. There are two parts involced inside the printing head: a gear and a pulley If you try to insert the filament from the right side, it tends to go out of the pulley’s track; especially if you try to push it hard.

The best way to insert the new filament is from the back, so the filament will not go out of track.

If your previous filament is already stuck, you need to take out the cooling fan by opening four philip screws to the heatsink. You should be able to see the leftover filament inside the head that prevented the new one to get through. If it is difficult to take out, you may need to open the nozzle as well, by loosen the allen screw at the bottom of the nozzle.

1 Like