Issue after updating to 4.0.1

I am also having issues after I updated to 4.0.1. I generated the GCODE for 3d printing and sent it to the machine. Though now the Y axis are not moving to zero position. Although the command is being triggered this is not moving back. I have posted videos and what i think of in this link on facebook. Further more I downgraded to 3.10.1 but then also this did not fix itself. So it is like a certain code has been passed to the machine and it is setting to 0 the axis in question. To check also if it was an issue of the rails or the wires, i have swapped these and the same issues were triggered on the different axis I switched it on. So that’s why I came to the conclusion of being a coding issue.

Videos of what I did in this link…

Any help would be greatly appreciated as I have a deadline for some work that I need to deliver

Share your gcode here please.
Did your machine work normal before Luban update?
How do you want to print? - Wifi, Serial, Usb thumb drive or touchscreen?

hi xhcrisd,

Actually I am not processing any Gcode. Just a simple homing procedure, the Y axis does not go back to home. But move upwards towards the far end. Now I am trying directly with the one of the horizontal axis only. So what I did was i connected directly the axis to the main board and it does not move downwards (towards me) but only moves up (towards the wall). Then I removed it from the Y switch from the controller and I put it in Z. Now it does come towards me but then the limit switch is not stopping it. It is being ignored. Though if I just move it upwards by 10 it comes to me by 10 but not anymore. Thus I am assuming that wherever it is, it is setting itself as 0 and if it goes up by 10 it resets itself to 0.

I am literally lost on how else I would try to solve the issue. And I have clients waiting for work without knowing what to do and what to test

Please make a video and share what you see, i couldn’t understand your explanation (maybe because of my english, sry).
Do you have a Snapmaker original or 2.0?

Does the machine home normal?
Could you jog with the touchscreen?

Hi Xxhrisd,

Finally I got it to work. The issue was relating to the limit switch on the Y axis. They were all filled up with wood remaining that passed when I worked with the CNC. I cleared up all the axis, tidied them up and to get it to work I swapped the head to CNC and then back to the printer and it then worked fine.

It had to have some normal maintenance and cleaning. Thanks