I don't get to focus the laser

Hi there, communiy!

I would need some advice about focusing the laser module. No matter what I do (±Z, rotate to set the focus) I don’t get not even close to the size of the point showed in the calibration card, so I don’t get to engrave anything. Any advice about how aprox. Z or aprox. lens rotation, or anything that can help me? Has anyone experienced problems focusing the laser?

Thank you!

1 Like

Hi @davidperez

Doug the newbie here. Try this, raise the Z axis to the top of its linear module, turn the focus ring all the way in to the head unit.

Note the diameter of the laser beam on the build plate object. Start lowering the Z axis 10mm each time and note the laser beam diameter each time. One would hope the diameter gets smaller. If you get to a point where the laser beam diameter gets smaller and then starts to get larger, use smaller jog ± increments to get to the smallest diameter. Make a note of that diameter. You could then change the focus ring and see if that makes a difference. Best case you will have a smaller laser dot, worst case is that you now have a detailed observation to submit a support call.


1 Like

Same here. Tried what Doug suggested. Still not working

1 Like

Hi @abouthui

Have you updated the Firmware and SnapmakerJS ? latest copy on https://www.snapmaker.com/download

What PC type and Operating System are you using?

The more information that you can provide then someone may have the answer or suggestion for you.


Just get it as small as possible. I don’t know that it’s possible to get it to appear as 0.5mm, but I’ve gotten some pretty thin lines on an SVG.

I am not seeing a focus laser at all. I was able to just tell the unit to run and it started to engrave but it was a larger laser area. I paused and lowered and restarted. I had to do this a few times until the laser was at a point that it would start to engrave. Did I miss something in the instructions that the focus laser will not turn on when I hit focus? When I click the focus button it states it’s turned the laser on at 1% but I don’t see anything.

The laser is really dim at 1% - it’s best to use white paper so you can see it when focusing.

HI got my 1600mW laser today and for some reason when I wanna focus the laser just go dead. It cuts ok but one need to focus before cutting please assist

Ok the new software sorted that out and the new laser looks promissing as it cut thru 11 pieces of A4 paper without being in focus, lets see where this goes

Hi @Pierre, the software is a little buggy (I have not updated to the latest version of SnapmakerJS). Here’s what I do to focus. Turn the power to 5% and turn on the laser. Then move the z-axis up and down to focus the beam. Prior to etching, turn the power back up. Hope that helps.


I seem to have a similar problem. I also got the 1,6W module. I get the laser dot to be very small, like the card, using a combination of ±Z and focus turn.

But it does not cut 1,5mm plywood. I “engraved” 2 packs of 1,5mm plywood (snapmaker shop stuff) with the outline of something I wanted to cut.

So it does not even work with 1,5mm and it was claimed it was able to cut 2mm…

What else can I do?? Am I doing something wrong?


Thanks that helps. i found that the easiest is to set it to 34mm from the surface
Works quite well

Maybe lower your speed of cutting, havent tried it but will soon

I have set it to 80 mm/s as suggested by snapmaker themself in https://www.thingiverse.com/thing:2982303

Did you set it to 34mm from the surface with or without use of the focus ring?

The Thingiverse page says 80 mm/min. That works out to 1.33 mm/s.

Yes of course mm/min. I used 80mm/min!

Judging from the movement speed of my snapmaker, the speed setting is correct. Also 100% power. Still no cut :frowning:

After two more hours of fiddling still no results. Does anyone have another suggestion? The laser is in focus. Power is 100% Speed is 80mm/min. No cut. Is my unit defect?

Hi All, so i find a quick solution in focusing the laser, and it might differ from machine to machine but not with such difference.
Actually its quite easy, once your material is secured. just lower the lens until it touches the material with a piece of paper between your lens and material.
Then Zero the origin and lift the lens to a height of 34.8mm, and zero again.
That should be your 0 level then for engraving.
You might have to adjust it by 0.05 up or down.

Thats exactly how i do it.
My smallest Laserdot (1.6W) is the on 32,5mm height.
But i don’t get reproducible results with the lasermodule, even when using the fine tune widget and get it to cut trough (2passes 65mm/min), on bigger SVGs with same settings the module wont cut trough.
I’m a bit disappointed by the laser and thinking about returning it to snapmaker. :frowning:

Instead, one could use the money for a >= 5W Laser w/ seperate Powersupply and attachon the Z Axis… :slight_smile:

Hi Henning, I use to have a huge machine with a 80W laser and learned a lot from that, i also have the problem with not cutting thru but I didnt expect more from a 1600mW laser. I was sort of expecting this when I bought it.
This small laser is actually just for small things like engraving on pens and smaller item to mark and if you wanna play, I wont send it back cause I know its gonna be a mission in getting your monies back.