Heated bed: NA°C after a few prints


Did anyone encountered issues with the heated bed? Mine shows “NA°C”.

I’m aware of the resistance-packaging issue and this is not the case (resistance ok). Printer used to successfully work, I tried another old RJ25 cable, tried to plug/unplug it, tried to disassembled the bed: nothing works. At the beginning it was after tenth of minutes that the temperature went out, now it’s from printer start-up…

Hi @a.delille,

Please fill in the warranty request, we will send you a replacement once the heated bed is identified as defective. Please attach a photo showing the thermistor is ok when you fill in the request. Thank you!

Hi @Rainie

I have the same problem here, but unfortunately I lost my invoice.
I want to know how to purchase a new one. Please help! thank you!

If you haven’t yet, you should just get a ticket in ASAP. The last thing you want is for your warranty to expire while you’re trying to figure out where a receipt is!

I don’t know if it matters, but I just wrote something along the lines of “I kickstarted this and received it in April” for that field and it wound up working out. Just put the information that is relevant and go from there, if it’s insufficient, they’ll let you know and request something better. I’m sure you’ve got an email that’ll help that could be used, if nothing else.

Hi @JohnnyLin,

Just to share the solution of this problem: replace the heated bed. After running some tests, the controller was wrongly identified as the source of the problem, it was replaced but didn’t solved the problem. After a second batch of tests, it appeared that the problem was either the heated bed or the cable (although I tested another cable).

I don’t know if it can help @Rainie identify the root cause, but I received mine with a scratch on the back that allowed seeing the resistor (see [https://photos.app.goo.gl/TcJwawqDKJg9kxq69](https://photos.app.goo.gl/TcJwawqDKJg9kxq69 on the bottom of the picture).

Hope you’ll solve our problem!