Heat bed stopped heating


I have been using Snapmaker for a few months now. A couple days ago, I was doing some printing and everything was fine. I went to print a design after one finished and the heat bed wouldn’t heat up. It shows it’s supposes to be heating to 50 degrees but it doesn’t move from 24-27 degrees.
I’ve turned the machine off/on, unplugged and plugged the heat bed back in, reversed the cable, and tried a design that had successfully printed before and the same thing happens.

There doesn’t appear to be any damage on the machine and I’ve really had no issues except this one. Anyone have any troubleshooting they’d try? I’ve emailed support and @Rainie but seems they’re all but bogged down as the email said it would take longer than 3-5 days for a response and I kinda can’t wait that long for support.

I’ve seen a thread about this before about a resistor not on the bed but I don’t see anything wrong with mine - and it would have acted up before this but here are a couple pix of it.

Thanks for all your help!

Mine did exactly the same?!? I used it last night to print a bracket I designed in Fusion360 - I made changes tonight, and when I tried to print it, the print bed does not heat up.

Did exactly the same steps you did as well - doesn’t work…so I figured I’ll have a look in the forum if there was a quick fix for this…

I still haven’t heard from anyone in the forums. I even sent @Rainie a DM but no response. I ended up contacting Support directly but they took a week to get to me. So, I sent in a service request and a week later, was sent something to fill out answering questions about the issue. They want videos and pictures of the issue as well but I went out of town before they contacted me back so I have to wait until I’m back home to get this resolved.
I’m irritated that it took this long but will be happy when this is all resolved and I can print with a heated bed again. Printing without a heated bed hasn’t been fun for me.
Your best bet is to submit a support request and let them know the issue. You may want to include if you have turned the heated bed option off in Snapmaker3D and tried the print that way to see if the target temp stays zero. I would also take video of the machine with the code with heated bed enabled and disabled just to show what it’s doing. Maybe you won’t have to wait as long as I have.

Good luck!

That’s the weird thing - I really need to print, so I was forced to find a work around. Right now I’m barely managing to print using Wanhao 3D printing tape on top of the sticker…but it also struggles when I try to print anything with long straits.
I managed to get it to working on an acceptable level by using rafts - but this wastes a ton of unnecessary material :frowning:
(…adhesion issues)

There is definitely some kind of communication with the heatbed though - if I use a hairdryer to heat up the build plate, the temperature sensor reliably shows the increase in temperature…but the system flat out refuses to heat it by itself.

I already logged a support request (CC’d Rainie in the email) asking for ways to test whether it’s the build plate or the control module that is at fault. I might not be an electrical engineer, but I’m not entirely useless when it comes to working with electronics either.
I don’t mind opening it to check for component damage or anything like that - but I’m not going to do it until they tell me to do so, because I don’t want them blaming me for damaging something that failed all by itself.

I have de same problème on my printer the heated bed working ones I squished de connection work fine for a while but today stop working for good
Is there a way around

So far, no. I have been emailing with support for the last 2.5 months and nothing has changed. I got a new controller sent to me and a cable, but they sent the wrong cable. Of course I received everything on a Friday so when I sent them an email, I had to wait until Tuesday at 1:30 am for a response. I did what they said and sent another video of the new controller not working.

I’m VERY irritated that I cannot use the Snapmaker as advertised and support is taking their time getting my issue resolved.
I wish they had phone service or chat - this would have been resolved within a day.

I’ll keep you updated if anything does end up resolving my issue.

Hi Ross, sorry for the inconvenience.
We have provided the solution to you but we sent the wrong cable.
Usually, our customer service agent will give a reply to mail in one or two days and offer you a solution once the problem is located. Hope you can understand.
We will provide a final solution to you as soon as possible.
Best regards,

I also got confirmation/feedback yesterday from them that the controller is faulty and needs to be replaced - however I want to buy a couple of extra spares and have everything shipped together, so I’m waiting on feedback regarding that now.

I got an email last night they are sending the correct cable this time as well as a new heated bed. I hope yours is just the Controller! I had the controller replaced but it didn’t help.
Good luck!

My heatbed still works fine - if I manually heat it before printing with a hairdryer then the temperature sensor correctly pics up/reports the changes in the bed temperature.
They sent me a document of tests to do on various things - like continuity and resistance values - so hopefully its only the controller.

Would be nice if they made that public! Would love to be able to troubleshoot things on my own.

I figure that it might be an IP issue - after all, they barely started shipping units, and those MOOZ idiots already tried to copy their system. For me to ship parts from South Africa back to them for testing is not very practical, whereas in EU and USA it’s easier because they have warehouses there if my understanding is correct.

Also, they did not offer it - I specifically asked them to give me the difficult/“end-user incompatible” tests that is usually given to engineers to do. I might not be an electrical engineer, but I know my way round electronics, and I work in an office that is filled with them, hehehe.
(so if I got stuck, help was literally on hand)

That’s a good point! I’ll have to see if I can get that. I know my way around electronics and would be nice to know what’s going on right away.

If they do have a warehouse in the US, they must not hav all the parts. It took me almost 2 weeks to get the first shipment. Or maybe they didn’t have any extra controllers on hand when I needed it. This time, tech said it would be 5 days so… here’s hoping!

Hi - I want to share my experience with those that may have had heat bed failures. I received a Heat Bed fail notice on my touch screen showing NA/60. I found my RJ25 coiled cord plugged into the Heat Bed receptacle however the receptacle has pulled away from the solder lugs on the bottom of the Heat Bed. This was caused by very weak solder points. There are only 2 solder points which are the 2 wings on each side of the plug. The 6 contact points are only pressed down onto the contacts and secured with clear cement.

I re-soldered the 2 wings on each side of the plug and made sure the contact points were clean and with a slight bend, made sure the 6 prongs were all making contact. No need to replace Heat Bed.

All is fixed and I’m happily printing again.


Mind does the same exact thing a few days ago. Was printing just fine then suddenly the bed wouldn’t heat any more even though the controller is trying to drive it to the set temperature.
I suspected the connector or the R15 resistor cracked or something. Any idea what value the resistor is? Mind is completely opened in the mega ohms.

This reply has come after essentially taking my entire Snapmaker apart (replaced the bed plate, heated the bed with a heat gun to see if recognized the temperature, etc.), only to find a simple solution. If your Snapmaker will not escalate the bed plate temperature, check the RJ25 connector cable. At some point either the bed melted or rubbed hard enough against the cable to do enough damage to render the cable useless. I have a small cache of Snapmaker parts in supply just in case, and once I replaced the RJ25 cable, full function was restored. The damage to the original cable was minuscule (very slight rubbing/melting damage), but it was enough to stop the function. Hope this helps someone else.


Sorry to hear of your challenges. Thank you for digging in and finding the cause. I’m sure that it will help others.

Is it possible to share some pictures of this?

I got my machine yesterday and the bed never did heat up so I haven’t been able to print anything!
Decided to attempt a laser engraving but, no.
why is information so hard to find???

Hard to know what you are looking for.

Maybe start here:

Did you perhaps update the firmware? I updated the firmware this week and I am experiencing the same problem now. In fact it prints and then it stops, I reset the machine and maybe it prints…