Has anyone els....?

After I installed the firmware v2.3.5 I have been been unable to connect to the internet.
I know the only reason is to check for firmware updates, and that is my concern.
This happened with the v2.3.5 update, that may have been corrupt or incompletely installed as it failed to print the vibration compensation tower when calibrating. That said it does print and I am able to send files by WIFI to the printer.
Should I try the update again from USB?

EDIT - tried the local update and still no internet connection. BTW I have rebooted the router, because I’ve had trouble in the past with smart plugs losing connection for whatever reason and reseting the router has always solved that.

Still V2.2 here but i’m unable to connect too, i’ve tried 2 different network with no success… i even tried a factory reset but nothing.

This is the same here.
I can’t update the printer any more, it says it is offline.

Same here, unable to connect - worked fine out of the box, now broken

This week is Chinese New Year. May be they shut down the server. I guess.

That is highly likely: They botched the latest firmware for Snapmaker 2.0, basically rendering the machines of many owners unusable, and I can imagine that they pulled the update server plug to avoid more bricked units…