Fixing filament runout always causes XY shift in the print

When the filament runout sensor (or clog sensor) says something is wrong with the filament on my Snapmaker J1 printer, it always is the case. When I fix the issue and load the filament, the printer has already homed the XY axis (and Z probably too). Now when the printer continues with the print, there is always a shift in XY. And this shift always happens. I think this is due to the homing procedure in between. I already have the latest firmware installed.

For that I wish to disable the homing feature in the routine of resolving the filament run out. I understood this is embeded in the M600 g-code command?

I would very much appreciate it if there was a possibility to not home during the routine of fixing the filament runout.

I am a software developer myself. As a last resort I could remove it from the code and recompile the firmware myself if needed. Of course, if there is a more user friendly way to achieve resolving the XY shift I would be more happy with that :smile:.

From the M600 g-code implemetation here, I read the following:

  #if ENABLED(HOME_BEFORE_FILAMENT_CHANGE)
    // If needed, home before parking for filament change
    home_if_needed(true);
  #endif

What ways are there to set HOME_BEFORE_FILAMENT_CHANGE to false?

Thanks.

It would be good if you let it the snapmaker devs know and correct:
Support@snapmaker.com or
Support Ticket Form