Firmware update issues

I have the Snapmaker 2.0 350 and I can no longer update the firmware.
I’ve tried via WiFi and via USB.
I have downloaded firmware file “Snapmaker2_V1.18.2.bin”

Tried via touchpad. Get to where it says download but pressing download does nothing. So, I downloaded the .bin and tried installing it from there and get the following error.

“Failed to recognize update information from file.”

Side note. Possibly related. After that error, my flash drive becomes corrupted and everything is gone from it.
Tried 2 different USB drives and have the same issue.
Thanks in advance for any help.

Sounds like a bad download. I had the same issue with the OTA update where it would just sit there on the Download so I had to fall back to the USB method which worked fine here (A350 as well).

The MD5 checksum on the copy I downloaded is 3ba5fa05c593c1d0ca9725da747d2d10 for the file named Snapmaker2_V1.18.2.bin.

To get the checksum:

MacOS or Linux: md5 <path to file>
Windows Powershell: Get-FileHash <path to file> -Algorithm MD5

If you get back anything other than what I showed, it’s a bad download. If it is the value you get back, I’d be checking your PC for malware…

I heard back from support and they sent a link to a file to format the drive to fat32. I also bought a brand new flash drive. Between the two, the update finally worked.
They are also aware of the firmware update bug from the display and are working on it.

1 Like