Failed to remove printed object

I just got my snapmaker 2.0 and printed the vase come with the software as a sample model.
The vase itself was beautifully printed, but removing it from the bed was a disaster.

I waited till it’s cooled down and tried scraping, tapping, applying alcohol,
but still couldn’t remove the bottom layer completely from the printing sheet.
Did I do anything wrong? Any suggestion?

I have the exact same problem. Impossible to remove my prints. Did 2 tests, and both were impossible to remove from the bed. I now have a big layer of PLA on the bed that seems impossible to remove. The only thing I was able to achieve are 2 bad cuts on my finger with the tool.

What are we doing wrong? Is there a way to clean the magnetic bed?

People who had the same problem reported these solutions:

  • Use Isopropyl alcohol
  • Heat the bed to 70°C (or more) and try removal then
  • Put into deep freezer for a while and try removal then

Never had that problem, so I cannot tell what works.

There was also a warning NOT to use acetone, it seems to damage thecoating.

In general: calibrate 0.05 - 0.1mm higher than standard procedure, since standard calibration is with cold machine. Also, print a skirt of a few lines and use the skirt printing process to fine-tune Z-offset on the fly.

1 Like

Thanks for the information.
Applying alcohol while heating the bed up to 70 degrees helped.

1 Like

There are two other things I tried:

  • Updating the firmware and running the calibration again
  • Applying a thin even layer of Elmer’s Glue stick over where the parts are going to be printed

Not sure how much impact the first one has, but the second helped me for sure.
Parts come off easily right after the print and they leave no marks any more. Hope this helps.