Dual Extruder problems?

I’ve tried my new Dual-Extruder on my A250a a few times, and so far have been quite frustrated (I’m by no means an experienced user, but was comfortable printing with my original single extruder).
I printed the example gimbal first, and while it did print, I could see gaps and ‘loose’ areas in the model. I’d tried adjusting the speed, temperature and/or width but everything I tried just resulted in a failed bird’s next! So, I went back to the original and still couldn’t get a print to complete! To me it looks like it’s under extruding:

The included white breakaway pla needs a higher temp. Look on the spool and make sure luban is calling it out correctly. Its not “just” white pla. Mine that I got working well is at 220 c for the white breakaway support.

1 Like

From your images, it looks like your nozzle is too high above the bed (no “squish” on the extruded filament). I suggest adjusting the Z-offset a bit.

The gcode for the Gimbal sets the heated bed temperature to zero! I didn’t notice this at first, so on my first print there was no adhesion and just a bunch of spaghettis, hair or frizz (whatever you want to call it). Is your heated bed also not heating?

To get around this, I found that setting the heated bed temp before starting the print didn’t work because when the gcode starts running it resets the temp to zero. What did initially seem work was to start the print then pause it and now manually set the heated bed to 65 or 70. Then resume the print.

But a few minutes into the print, I had the same issue experienced by Steve (the OP).

So, maybe I too have a Z offset issue However, I note that printing the calibration models or the calibration check model did not have adhesion issues.

If a Snapmaker employee is reading this, please note the heated bed bug and maybe also a Z offset bug in the built-in Gimbal example.

I noticed that the ‘other’ printhead’s temperature was set at 0 at the start too, and manually reset it to 200C. Then I noticed that after printing from 1 head, when it switched to the other, the first head cooled down (to 160 or so) until it was it’s turn to print again-then it heated back up to 200 before starting extruding. The 2nd nozzle did the same, so I think that was part of the design (to prevent oozing).

Bingo :slight_smile: That worked for me! I lowered the z-offset 0.25mm (a bit too far, but at least now I know what to adjust) and my next gimbal test print came out just fine :slight_smile:

1 Like

It seems that 1.15.19 had a bug in it that after Z-Calibration the print height was about 0.3 mm too high - I have not yet tested with 1.15.20 - hope they eliminated that…

The bed temp issue is also elsewhere on this forum: Luban sets Bed Temp to 0?

But the problem gets weirder. Today, I tried again and now the bed temp is 65. My adhesion problem has also gone away, seemingly on its own.

Snapmaker is unclear as to whether to use the breakaway PLA in the right extruder or to just use a contrasting color. Yesterday when I first encountered the problem, I was using ordinary PLA. Today I tried with the breakaway, but still had adhesion issues, although significantly less than yesterday. Then I decided to try ordinary PLA in the right extruder and now I don’t have any significant adhesion problems at all.

They have not. I’ve had to manually adjust the Z offset.


To solve this problem, and it definitely looks like a bug, toggle the Left Extruder from Fast Print to Precise and Strong and then back to Fast Print. Now the bed temperature properly gets set to 65.

I compared the two gcode files and note that when you don’t toggle the extruder as above, then there is no bed temperature command in the file. The left file is the one you get when you don’t toggle and there are no M140 or M190 commands in the file. Those commands appear if the file is generated after the left extruder is toggled.

1 Like

Has anyone developed a Cure profile for the Dual Extruder?

Yes you are right, i had to offset - 0,35mm both extruders too, also with 1.15.21 (not sure if 20 or 21)…

1 Like

By now there are several posts in this forum that show Cura profiles. Mine is here: Cura & Dual Extrusion head first try - but I’d not deem it perfect. According to a Facebook post the newest Cura has a profile for it, but I cannot find that post anymore, and I installed Cura 5.3.0 today and could not find it - if it really is there, it must be in the beta.

1 Like

Thanks Hauke!