Dual extruder calibration example

My first print:

tried again and after the circle was messed up again I changed the right nozzle temperature to 200 degrees manually all the time, it comes out like this:

I did the calibration using black & white PLA (and also a new sheet), not breakaway PLA (as my first attempt using this failed too).

The instructions in the manual aren’t unambiguous anyway. Once breakaway PLA should be used, once only two different & distinct colors.

I think this is a bug/slicing problem in the GCode for the calibration model. The nozzle that is currently idle is set to 150°C cooldown/standby temperature, and shortly before it gets used again set to 185°C “warmup”. Only when its job really starts, it is set to 200°C, but the hotend is not waiting to reach 200°C and starts off right away. I did my first print with Cura in dual color recently, and Cura uses the “wait for temperature” command, so no issues there.

So, I guess Snapmaker needs to update their hard-coded calibration model. I was also wondering how you might print the calibration model at other temperatures… I do not remember the wizard any more, but I don’t think you were asked for the temperature, were you?

1 Like

well, I swiped on the touchscreen while printing, you still can set temperatures there…
Everytime the temperature was set by gcode to 185, I set it to 200, so it was 200 or near when it started - I will print the Luban included “gimbal” and look if the “wait for temperature” is working there

did you have any success with calibration check while printing white at 220…

and gimbal model?

I ve taken a rest…

so that I can keep my sanity

seems little or no quality control???

I did not try printing white at 220
the gimbal model worked out quite ok

now I’m facing more and more problems…
I tried after a couple of days (printer switched off) a regular model, no test print. I used Luban 4.5.1 when the print started about 3cm above the sheet - no matter what I tried. First thing I did - I was looking for updates in Luban, it said there was an error looking for updates. I found 4.6.3 on the snapmaker site, installed it and tried my print again - same issue. So I had no other choice than calibrate everything again. In Luban I found that I can only connect via WiFi; connecting USB will result in showing me, that the single extruder would be connected. With Wifi connected, I can not change temperature while printing, the console does not show anything (except “connected via Wifi”); remaining time will stay the same all the time, the nozzle temperature for Left nozzle is shown as 35°C although the touch screen says 222…
The settings for prints in the slicer are ridiculous - I remember when I could choose between normal, fast and high and it would set a lot of things automatically - now it looks like everything is set by default and if I choose custom I have to change everything manually…
Looks like there are still lots of issues…

Edit: lots of those issues are already known - found a thread: Luban V4.5: Known Issues & Corresponding Solutions

I had to recalibrate again, after I switched the machine off - again it started printing about 3cm over the sheet (printing into air)
Could it be, I used the “wrong” mounting holes???

wish i could help but im stuck with stringing and/or calibration issues

I mounted the print head the way the manual says - I will see, if the re-calibrating issue will disappear.
Other than that I’m having issues with the print settings… I seem to get no solid object out of the dual extruder and I don’t know if this is a calibration or a settings problem
The model in the pic was meant to be solid (100% infill)

The image looks like you’re printing too high. Perhaps try to use the on-the-fly controls to fine-adjust the Z-offset.

I think you’re right… on the fly seems not to work while the machine is connected via USB - maybe I will try via WiFi and/or calibrating Z manually instead of automatically…
Lots to learn and find out …
e.g. I wondered why my models in Luban seemed to be “topless” - you could see the infill - so I found out that I simply had the upper layer set to “0” :wink:
all in all I have to admit that the prints look way better with my dual extruder (even when I print only one color) than with the single one (it is my third one due to ruining the first two) - I had so many issues with warping, stringing, adhesion and so on.
Next challenge for me - printing in two colors… since I create my models in Sketchup, I don’t know how

I got the same problem. It looks like the temperature that I set is reset when printing the test model.

Update on my issues:

  • I mounted the print head on the “right” holes - now I don’t need to re-calibrate everytime I switched the machine off and on - it keeps the settings
  • printing with USB-connection still shows “single extruder” connected - but prints in two colors without trouble
  • calibrating Z manually did the job, now I get a proper first layer other than shown on the picture above
  • printing in 2 colors using Sketchup as a modeller: I simply have to build two stl-files and save them separately; put them in Luban and set the different nozzles for the different parts; I designed a little test cube with two colors - worked out well

for me it does not look that bad compared to my first attempt :smiley:

Now upgraded to firmware .20
I now also understand the problem with setting the temperature. The right hand nozzle temperature could only be set when it is active. So it wont take any changed settings until then. A clear bug.

And, why do I get blobs of filament. They connect with the print and then tours the print away when the head is moving over the blob. It looks like the retracktion is not properly set for the test model?

More bugs, when chenging the temperature on the display for the test print it wont change the target temperature.

The automatic z ofsrt is going to high dispite calibrating the sensor with a paper.

I set this temperature to 210. And it shows target 185 plus 185

Stil problem with tthe inner cicle with version .20

I think the temperature is to low. And there is a green blob in the circle.

My impression is that the model for this check is hard-coded into the firmware, i.e. it is GCode pre-sliced and just stored away somewhere. I assume they sliced with 200°C pre-set, and there’s no way to override this. So better use PLA that prints well at 200°C :slight_smile:

That said: Your result looks just right! Perhaps X/Ycalib can be slightly better (gap in the “north” is larger than in the “south”), but the green blob in the circle is “intentional” in the sense that the circle is the purge/wipe tower and intended for getting rid of oozing filament. That the red circle is not perfect - again an indication of X/Y calib not perfect, but otherwise IMHO of no consequence. The purge tower is supposed to be discarded anyhow.

Don’t worry about the wipe tower, it’s doing it’s job, you only need to focus on the calibration model. When the extruder is going to the wipe tower it’s still getting up to temperature so it won’t be optimum, it’s also used to re-pressurise the nozzle so it will under extrude and may blob as well. In addition, the extruder that has just finished, will wipe itself on the tower so you may get a blob from that.