Driver for ESTLCam

I have tried to make files with EstlCam but they don´t work what can i do to fix the problem

Anymore info? I just tried a dxf file and ESTL seemed to give me a useable Marlin output. I am nowhere near expert in these things but I have been able to use MeshCam to produce workable code for My A350 with minor edits. What I see out of ESTL looks like it should work without edits. I will test it some time in the next few days and see what it does or doesn’t do.
Did you select Marlin for the post processor?

1 Like

Tested ESTL Marlin output from a DXF created in Solidworks. The Spindle starts and runs full speed, all of the tool motion looked appropriate, I cannot tell for sure how fast the spindle is turning. I didn’t do a comprehensive test I ran a simple program in space didn’t cut any parts. ESTL looks like a great deal for $59 the ability to generate Marlin/Snapmaker GCode from a DXF is good enough for my money. ESTL does all kinds of other useful looking things also. I think the average SnapMaker CNC user would do much better with ESTL than Fusion. I have not tried any STL carving so YMMV.

Snapmaker does have custom M3 command it is not the same as default Marlin. If you want to control spindle speed in the Gcode from ESTL an edit will need to be made. ESTL outputs M03 S24000 to turn on spindle at 24000 rpm (spindle is 12000rpm max I believe ). Snapmaker has customised the M3 command as listed below. The command is (M3 P100) which commands the Snapmaker to turn on the spindle CW at 100 % speed or (M3 P50) for 50 percent speed. Editing Gcode in Notepad ++ is very easy.

Snapmaker Commands for M3 from Snapmaker GCode spreadsheet.
[P]: laser power or spindle speed (clockwise), range from 0 to 100
[S<power in strength>]: laser power or spindle speed (clockwise), range from 0 to 255"

1 Like

Tanks Ron for your anser

I have tried almost all the setups in Estlcam, Marlin as well; maybe I have some of the many settings wrong. Those I tried worked nicely, like this, The Snapmaker 2 make a home run than it goes to work origin and if I ask for a boundary test it chases I have not come as far as altering the M ( M3 P 100) command

Is it possible to tell me how you set up the other parameters in ESTLcam.

I would like to use ESTL instead of F 360 witch I fined very heavy and untrustworthy you don’t know when they close down on you. For STL files I use the free program Design Spark Mechanical you can make your DXF files with DSM a very good program.

I am not used to write in English so bare with me

1 Like

Hi Ron, don’t know if you saw this before I edited it out: Lightburn Device Flavor - "Snapmaker", not "Marlin". Maybe it has uses outside of Lightburn, where there was a better way of doing what I was trying.

I had a Notepad++ Python Script for changing the Marlin M3 command and calculating the Snapmaker one. I just modified it to add M4 as well.

# Expects 1 match: S 0 to 255
def calculate3(match):
    return 'M03 P%s S%s' % (str(float(*100.0), str(int(float(

def calculate4(match):
    return 'M04 P%s S%s' % (str(float(*100.0), str(int(float(

# Match like M03 S1.275
editor.rereplace('M0?3 S([0-9\.]+)', calculate3)
editor.rereplace('M0?4 S([0-9\.]+)', calculate4)

Gets run like this:

1 Like

Maximum spindle speed is 12000.
When you’re running a job it will show the spindle speed on the control pad.
It’s helpful when running harder woods to be able to see if it’s bogging down on certain moves.


1 Like

Ok Ron
I have tried the settings you recommended and it looks like it works OK if you simply run the file.
But in the first screen on SM2, see the enclosed picture, a huge number can be seen in the place under the file name where the size of the job use to be, and when I run a boundary check it gives me the screen with the “FabScreen has stopped” I enclose the cnc file I ran when this occurred maybe the Forum can see what is wrong in the cnc file.

KEY.cnc (2.5 KB)

Well there’s your problem, your toolhead is 35967872420077830000 lightyears to the left.

??? lmao no idea why the touchscreen crashed, the gcode looks fine, except for it’s calling for 24000rpm on the spindle. Try changing the 24000 to 12000

1 Like

Thanks Brent
I changed my spindle speed but I still get the “FabScreen has stopped” whatever that means!
I looked in a file of the same object made by LUBAN I can´t se any where a line sending the size of the job
Except if it is hided in the graphic “chitchat” in the beginning of the file.
Has anybody experienced the same as me please let me know how you resolved the problem .

Just for testing purposes you could remove the image and other junk and see if that fixes it.

Hello, I’m having the same problem. Have you found the solution? Could you please share?