Discussion of Snapmaker Artisan Firmware Updates

An option to turn off notifications (e.g. when a file has been sent to snapmaker) would be great.
A stop button when loading/unloading the filament would be great.

1 Like

latest 2.2.4 here:

latest 2.3.1:

With 2.3.1 the show border wtih the laser is not working correctly.
I move the laser to the top left corner where it should start (file also top left corner).
Show border moves the laser also to the left, this is false.
I used the emergency button.
When i start the laserwork it works correct.
File is made with lightburn.

Has this bug been resolved with the newest firmware update?
I have so far refrained from updating because of this.

Here is the changelog:

This bug is solved!

1 Like

It seems the print head is too close to the bed in those failures.
Try to manually elevate Z while in a print (+0.4mm works well for me).
Remember to elevate both left and right heads.

Precisely the same issue. First calibration and 3 prints worked fine. Attempted a 4 axis CNC. It was not successful and never could properly calibrate. Back to 3d print head and cannot calibrate z axis. Using latest firmware post May 2023 update. Has a solution been provided?

1 Like

I updated my firmware last week to Snapmaker2_V1.15.26. I have encountered many bugs. From the touch screen showing that there software disconnected from the machine, to the remaining time on the touch screen being twice as long as the actual print time. Is there a way to reinstall an older version?

Here’s a list of the firmware downloads:

I read somewhere that rolling back to older firmware is to be done using USB and from the console, not over wifi…

Hope this helps.

(The latest version is not what you mentioned. That latest is v 2.3.1. Are you sure you updated to the latest? Are you talking about the Arrtisan or is it another machine?)

Very true on the firmware issues. Have had my Artisan about a month now. The first 3 3d prints …2 single print head and one dual print head with breakaway material in one all worked fine

Attempted a 4 axis CNC …could not get it calibrated.

Reinstalled 3d print head…after 10 factory resets and many… many attempts to recalibrate I have been completely unable to use the artisan at all. No help from support beyond 4 days between responses and each asking for more info…so unusable for the last 3 weeks.

FW v 2.4.2…but last 2 FW versions had same issues.

Can’t manually calibrate either…the calibration menu page is blank until after a successful auto calibration…auto calibration is failing…z axis proximity sensor must not work as print nozzle strikes print bed hard…never calibrates. If I make it to xy calibration the Left head scrapes the print bed and R print head is about 3 cm above the print bed. X calibration will save…Y won’t save at all so calibration never completes.

USB (either the port or the thumb drive) stopped working after FW 2.4.2 installed…not certain a connection exists.

No way to escape starting at auto calibration without disconnecting print head before powering on…no way to try any trouble shooting without factory reset first…

So right now the Artisan is very frustrating. And right now I would not recommend it.

Same problem and even worse. I reset the printer to factory settings and now when I turn it on, when the printer wants to calibrate and load the filament, the head goes so low that the nozzles peel off the coating and I have to turn off the printer using the safety button. Is there any chance to skip the calibration and set it manually? Is it just a product complaint?

FW 2.4.2

Action host commands are disabled?

Did anybody try the m600 on dual extruder? Does it work on both sides?

I would like to turn on/off enclosure leds while printing from the controller. Now I need to start Luban to do that. Thanks.

There is indeed a bug in the latest version of the firmware. When the laser module is not connected, only the M2000 S command can be used, and other commands cannot be used.

No you don’t. Tap the gear icon and scroll down to the Enclosure selection. You can toggle the LEDs and the fan from there while the print continues. It took me a while to figure that out.

Firmware V2.5.17 Bugs:

  • Laser does not switch off while setting the working zero point and the door is open.

  • I like to work with Lightburn. Since the inline power mode is implemented and I have created the gcode with lightburn (e.g. 3 squares) then only the first square is lasered, for the other squares the laser power remains at 0. I think inline power mode is not yet cleanly integrated in the firmware.

Will the firmware source code be open sourced so we can modify and or resolve issue as desired?

1 Like