Controller app hangs before start engraving with firmware V1.7.1.1


I’m currently working to make PCB with laser engraving + chemical etching.
To do this, I’m using FlatCAM to generate laser engraving G-code from gerber data.

The G-code worked well before upgrading to firmware V1.7.1.1 yesterday.
After upgrading, the controller app hangs before starting engraving.
The UI of the app is responding and I can press “Pause” button, but after pressing the “Pause” button, the UI also hangs.

After some investigation, I found that G-code files without appropriate headers (section surrounded by “;Header Start” and “;Header End”, which SnapMaker Luban outputs when exporting G-Code) cause the controller app hang up.

Copying the headers from a G-code file generated by Luban to the head of the G-code file generated by FlatCAM solve the problem and engraving finishes successfully.

So, I doubt that the fix of comment parser in the V1.7.1.1 affects this problem.

Are there anyone who also crashed into this problem?

Thanks in advance.

We should get this up to the support @Edwin
For me it happens at gcode comments at 3d printing, but it was a commented comment line which is okay to not understand like:
G1 Y100 F300; comment to go to Y100
This is what de bug occurs

Good to know people who give a bug feedback @ciniml :+1:

Many thanks to @xchrisd. Could you please send me the G-code file and I can check the Head Start and reproduce this issue. @ciniml Thank you in advance.

Hi @Edwin

I’ve uploaded G-code files. (111.4 KB) (110.8 KB) (141.1 KB)

First 2 files fail to engrave and controller hangs.
The last file has headers copied from another G-code file generated by Luban, and I’ve confirmed that my SnapMaker 2.0 A250 with firmware V1.7.1.1 can engrave with the last file successfully.

When “” is opened from Files app, the work area value is invalid (± max 64bit floating point ?).


Sorry for the late reply.

I have downloaded the files and will check it later and reply you here.

Please upgrade the latest firmware via this link:

I’m trying the same thing but am struggling with the Flatcam process. I see where to generate the CNC gcode, but have no idea how to make that work with the laser module. There doesn’t appear to be much in the way of help in the Googlesphere about this either. I’ve also looked into the laser extensions foe Inkscape, but loading the gcode generated into luban makes the software hang… Any help would be appreciated.

Hi @00coday .

Here is my article which describes how to generate G-Code for the laser module with FlatCAM.
(Sorry, it’s in Japanese. But I’ve confirmed that Google Translate translates it to English well.)

I hope it helps.


@ciniml - I can’t thank you enough for the tutorial. Google translate was a bit rough, but the images helped a lot - I just pulled my first laser etched pcb out of the ferric chloride and it turned out awesome! I appreciate the time you put into your tutorial and that you shared it with the rest of us.

Next step - get the CNC module to mill the holes… I think I have that one figured out. Its not strait forward, but I think I can get it to work… I’ll post back with an update

1 Like


Has anyone resolved this issue yet?
I just started using flatcam to try and drill holes for my PCB but the controller crashes when I try to do “Run Boundaries”
I have tried different firmware including the latest one and it does not seem to work.

It’s been a while since I used flatcam, but never have gotten the run boundaries working. In general. just don’t run boundaries, the rest works :sweat_smile:
(I usually ran the job, or part of it, like the final outline about 5 cm above the workpiece to validate first)

1 Like

Not really the answer I was hoping for …
But thanks for the reply :slightly_smiling_face:

btw … which firmware are you using?
Are you removing any lines from the original Gcode file?
I saw another video that recommends to remove all lines that are in the parentheses.

I don’t know for sure anymore which firmware version that was. (Currently I’m on the last version, but haven’t done anything with flatcam lately). I would guess it was the 1.8.x version.

I did remove all comments from the cnc files. However, I also did end up generating different files for different parts of the path and manually combined them in one file. But even with individual files without modifications, I never could get the run boundary working with flatcam generated files. I briefly did try to find out what caused it, but couldn’t get it to work.

It does work for jobs generated by Luban and Fusion 360.