Can't connect to my iMac


#1

Hey guys
Just got my Snapmaker yesterday, I installed the driver for mac, restarted my mac couple times.
but in the port section, there is nothing I can choose.(expect for some of my bluetooth speakers)
Is anyone having the same issue?


#2

Running High Sierra? If so, there are known issues with more than one USB driver. I immediately went to an OctoPi to use as a print server and just upload G-code files to it.


#3

Try searching for a port after connecting the USB cable at different moments of the process, eg. connect the cable before turning on the printer, after turning on the printer, before opening snapmakerjs software, etc.
I have a Mac mini and sometimes it doesn’t find the serial port straight away.


#4

Does anyone know if the Snapmakerjs software is compatible with all levels of the Mac OS?
Are there any known incompatibilities? I am running an iMac under El Capitan and cannot get Snapmakerjs V. 2.4 to start. Is there any information anywhere on the Snapmaker web site that outlines the System Requirements for Mac?


#5

Yeah, I’ve had some weirdness with it. Sometimes I have to launch it two or three times before it stays running. I’m running Mojave beta.


#6

Anybody using Mac OS El Capitan V. 10.11.6 with any success?


#7

What’s your configuration? Which Mac? What OS?


#8

Thanks, I tried like u suggested. Before and after, plug and unplug several times. Still couldn’t find it…


#9

iMac 27 Mid 2015. Mac OS 10.13.4


#10

Haven’t meet any issues with connecting to USB, but I found some information on the repo.

Troubleshooting

If, and only if, the device is not recognized after the installation (or you cannot install the driver), please disable System Integrity Protection:

  • Reboot your Mac into Recovery Mode by restarting your computer and holding down Command+R until the Apple logo appears on screen.
  • Open the Terminal (Applications > Utilities > Terminal).
  • In the Terminal window, type in csrutil enable --without kext (or to fully disable: csrutil disable) and press Enter.
  • Restart your Mac.

Since disable the System Integrity Protection can be dangerous, backup your work before doing so.


#11

Thanks. I trashed the downloads a couple of times and retried the download. Finally got Snapmakerjs to launch. Success. On to trying print/carve/engrave. Thanks to all who responded.


#12

Hi! It seems to be tricky! I have tried with a macbook pro 15" 2015 and Mojave, without any problem. Then I tried with a macbook pro 13" mid 2012 and Mojave, and most times snapmakerjs does not load the port module. Once it did it. Then, by opening snapmakerjs in a window in a browser, it includes the port module. What is happening? I don’t understand.


#13

@wvalderrama Some times will face problem to use Snapmakerjs since the compatibility in different computer.
Not sure if you installed the driver,thanks


#14

Yes, I did. If I reset the configuration, the port connection menu reappears. 8-( ???