Cannot Connect To WiFi

Hi There,

I am having some trouble getting my Snapmaker 2.0 to detect my WiFi. My SSID is not hidden and I can see neighbours WiFi listed on the Control Screen but not my own. Other devices are able to connect fine. The Wifi runs over both 2.4 and 5 GHZ.

I have also tried setting the WiFi to just run on 2.4 or 5 GHZ and updated to the latest firmware.

Any ideas apreciated.

Hi davotronic5000,

Could you check which channel of the Wi-Fi is being used on your router?

It seems like not just the weak signal issue, so we want to run some test for it. Sorry for the inconveniences.

Hi Alan

The 2.4GHZ is on Channel 2, and the 5GHZ is on Channel 52, although when I have booted the machine up this morning, it has detected my WiFi without any issues, so this may have resolved itself.


I am having the exact same issue, SM2 is not seeing my Router, channel 132, 5Ghz, -50dBm
My wifi analyzer sees lots of networks, 23 incl hidden. SM2 is showing just 2

ok sorted it, did a complete reset of my router by a paperclip into the reset hole. Which wiped all the passwords etc which I had to set up again, but the 5Ghz is now showing on SM2.

Its a wifi channel issue.
Its ok and connected on 157, but so far 132 and 108 it won’t connect.
Is the SM2 limited on wifi channels? jeesh

Also a delay discovered in the wifi network list, I have to go out to another menu and back in before it picks up anything new. Even wifi off and on makes no update.

Looks like the touchscreen wifi chip is compliant with Mainland China Wifi Channel restrictions:

Would be worth asking if that’s something that can be software patched for the rest of the world.

That could be the Wifi issue for lots of people right there! And potentially the camera also!
Changed to 149 and that worked too and seems to match your theory from that China wifi list.

  • Improve Wi-Fi connection and remote access from Snapmaker Luban.