Calibration alignment


#1

I just bought a 3 in 1 Snapmaker printer in December 2018. It‘s a wonderful product.
This product came with the 2.4 firmware.

I updated to firmware 2.6 (with enclosure) to have the enclosure door option.

Since I updated to this firmware, in calibration option, the nozzle is out of the heat bed (3mm OFF) for the point #1 and #4 and more inside the heat bed for point #2 and #3.
When I print the model is not in center of heat bed.

Do you have any solution to patch it and recenter the alignment ?


I can't print on the whole surface of the bed 125x125 / Je ne peux pas imprimer sur toute la surface du lit 125x125
Randomly x-y-offset while printing
Bug Reports and Feedback for Snapmakerjs V2.5.X
#2

Did you attempt calibration before you updated the firmware? I’m wondering if it worked correctly on 2.4.

I was running 2.4, so I updated to 2.6. My calibration points are all still on the the bed. I do need to recalibrate now.

You could be having the same issue that edeiller is having.


#3

It’s only when I use the firmware 2.6 (See picture below for point #4 calibration).

I’m gonna back to 2.4 and I don’t have this problem.
It’s a similar problem but not the same problem as edeiller having because with firmware 2.4, it’s perfect on the bed.

I need the firmware 2.6 to have the enclosure option on software.


#4

You might give the v2.7 firmware a try.

Some people in the Firmware bug reporting discussion are saying they had a different issue, but it went away after downgrading and re-upgrading.

If neither one of those fixes it, I’d add a comment to that thread, linking back here.


#5

Same problem with 2.7.


#6

Try to diconnect the enclosure switch!
I have malfunctions on the z-axis, once i connect the enclosure switch and close the door.
Disconnecting the door switch solved the problems.


#7

hi @Manu Did you make sure that you have installed the X axis correctly? Check out the illustration here, page 9: https://s3-us-west-2.amazonaws.com/snapmaker.com/download/manual/3D-Printing-webview-V1.0.1.pdf


#8

I double check all axis to be sure.
This problem is only with a firmware 2.6 and up. I think it’s not a hardware problem.
When I’m back to 2.4. It’s work fine.


#9

Tks so much for your help. That’s work fine.
I turn OFF the printer, disconnect the door switch, and turn ON with the firmware 2.7. The calibration alignment is back to the normal position.


#10

Tks so much to everybody for your help.


#11

Door switch seems to be a major bug in the last firmware versions. Let’s hope, it will be fixed soon.


#12

I had the same bug, using 2.6 and 2.7. Don’t know, how it was with 2.4, since I connected the switch when upgrading to 2.6.


#13

On firmware 2.4, I think the door switch is not detected.


Bug Reports and Feedback for Snapmaker-GD32Base-2.X
#14

Just wondering, did you perform a reset before calibration after upgrading the firmware?

I’ve just added the enclosure a couple of days ago and have left the door switches unconnected to the controller and have not yet upgraded the firmware or software (as I was in the middle of a series of prints and didn’t want to contend with any possible glitches.

I find it odd that if this is indeed an issue, it has not been properly acknowledged or addressed by the SM Development Team.


#15

No need for me. I just recalibrate the 4 points.


#16

It is not a matter of calibration. When the door switch is disconnected or the door is open, everything is fine. But if the switch is connected, it is getting funny once you close the door.


#17

Hello, Im completely new to 3D printing and my snapmaker just arrived. For the life of me, I cannot get the machine to calibrate correctly. I’ve went over everything several times with no resolve. Ive reset it, tried to move the axis down to get the nozzle in the correct position and still cant get it to work. When I try to move it downward, the machine will not respond after pushing down 3 or 4 times. I just cant get the positioning right. I am a complete noob with this so any help will be much appreciated. Thank you again.

Dominic


#18

Hello, and welcome.

First of all, you cannot use the touchscreen if you have a computer connected via USB, I’m assuming however that this is not the case.

Upon switching the machine on, always execute the Home axes before anything else. The jogging commands will not work properly if you fail to do this.

After homing, the next step would be calibration, and then saving the result.

Next would be filament loading and then you should be ready to print a file.