Artisan first impressions: awesome device but some help wanted

I also noticed that the first layer is too high. Other layers are at the correct distance.

Probably a setting in Luban. But I come from Cura and do not want to deal with Luban as a slicer.

I also did the update to V2.0.16 and after that the autofocus did not work.

I downgraded to V2.0.11 and it worked again.

But when I take picture with the camera and place my engraving on the photo, the laser goes somewhere. I have calibrated the cameras.

I also have the problem that the connection to the air purifier keeps giving an error code “7-1”. If I first turn on the power supply of the suction and then the Artisan controller, then it usually works.

Regarding your laser problem: You can switch to manual focus when starting the job and manually set the height using the calibration card.

How can I find manually the focus? I also hav troubels with the laser calibration… but I do not use luban… I only use lightburn because i often need different layers for layer engraving and cutting…

Start the job and tap in to the right top corner as shown in the picture from my last post.

then tap “manual focus”

You can move the axis to your defined start point. Z-Axis should be 10mm above your workpiece. you can use the calibration target for setting the height.

I don’t think anyone has addressed your question about the “strange cylinder” yet. This is sometimes called a “purge tower” and it’s used by the printing process to help keep the extruder clean which improves print quality. It’s probably better not to try and print without it, at least until you get things running well.


I was about to downgrade the firmware when I noticed a new firmware update: v2.1.1
Upgraded to this version.
Recalibrated for the laser (thickness, bed level and camera) and then again took the ruler example.
Now the laser did seem to work. Markings are nice. However, it did not completely cut the rulers out.
Wasn’t it supposed to do that?
The cutting tool path is set to 1 pass and 100% power by default.
Would a second pass not cut it completely?
Or still something wrong with the automatic thickness measurement why it did not cut it in a single pass?

Short update:
I did a second pass of the cut lines at 100%. Then most of it was through but not enough to get it out easily.
Did a third pass at 75% and then was able to get the pieces out. Had to sand some edges.
But looking good.

My Artisan is here and mounted.
After calibrating and printing the 2-color pen cup, I did a first test with TPU.


hi - where do I find the Firmware 2.0.11 for Artisan for downgrade?

I got mine also this week. Quality of packaging and device are just impressive. Assembling worked fine. But I have already with 3D printing my difficulties. While setting up it upgraded to current firmware and I use Luban 4.6.3
The testmodel was not good. Then I tried a simple 50x50x0.4mm solid body (made with fusion). The threads are very weak and can pull off as one line. Putting the material flow to 200% made it a little bit better. But the surface still not closed. Looks like there is too less material. You can look through the solid parts. Quite disappointing.

This is already with 200% material flow. Without its hardly to get down the plate in one piece.

1 Like


which FW and Luban version did you use?

@MP_Trixi u can download each release here Snapmaker Artisan Firmware Updates and Downloads

1 Like

I Use the newest Firmware i think 2.1.1. Luban is 4,6,3.

For Black i use 215 centigrade and 225 centigrade for the white Pla.

Strange. I have 2.1.1 (the one with german language support) and Luban 4.6.3.
And it do not work (had default settings). Have now Luban 4.6.1. Now I installed 4.6.1. It seems better Trying now a more complex model

Results with Luban 4.6.1 and FW 2.1.1:

Left one with Luban 4.6.3

Hi @MP_Trixi i use Luban 4.6.3 and FW 2.1.1 and it looks good.

I upgraded firmware after successful calibration of my new machine. But after the firmware upgrade the prints are quite underextruded and the x hight is too low.
Did you downgrade the firmware?
How did it go after that?

About the Pen Holder: it’s problematic. It’s a combination of the model, the firmware, and the material settings. Other models will make for a better first print to troubleshoot. Short story to fix some of your problems:

  • Luban’s material settings for the standard black PLA and breakaway PLA that shipped with the machine don’t quite work. I set the print temps a little lower and the hold temps a little higher. You’ll have to play with the settings yourself, each setup is a little different.
  • The extra cylinder is called a Prime Tower. The tower caused my print to fail so I turned it off and compensated with tighter control of my Standby Temperatures for each material. Screenshot for how to turn that off attached. Good luck!
1 Like

Not sure if this is the right place. Can anyone comment on the actual required space needed for the Artisan. There is obviously the machine in the enclosure which is approximately 26" x 37". But then add things like the air purifier, spool and spool mounts mounts, exhaust, controller box, etc… Does anyone have a realistic footprint for all this comfortably? Prepping for arrival someday.

Thank you

I have a 75 by 120 cm (29.5” x 47.5”) table and got the machine on it, but uncomfortably. The control is lying oblique at the back of the machine, prone to falling. I also got both spool holders on the same side to save on width space. Adding 30 cm in width will be good enough to get everything where it should be .
Depth wise, the air purifier stands comfortably behind the machine, and the door is just 2 cm behind the table edge, so no issues in 120 cm of depth, but adding 10 cm would make it great.
So the bare minimum is a 105 cm in width (or 100 if the spool holder can extend out of the boundary of the table, or if you attach the second spool holder on top of the first one as I’m doing) by 120 cm.
Comfortable size is:
110 width by 130 cm.