Artisan Assembly

Finally got the Artisan. 2 big boxes delivered 2 days apart. The weekend in between was brutal as there isn’t much you can do before box B arrives.
Got a question. I can’t find anywhere in the manual where I use the “L Bracket & M4 x 12 Low Head Cap Screws” that is included in box A5 with all the other bags of screws.
Went thru the manual. Went thru the online manual. Nothing.
Am I blind? Has anybody figured out where this goes? Is it a spare repair part?

Other feedback:
Allen wrenches aren’t great. With the 2.0 you got a nice screwdriver. With artisan you get cheap Allen wrenches. If you have your own wrenches you might have an easier time.

Enclosure converter isn’t in a great spot. Trying to connect the switch, led’s and fan will be a royal pain. Fortunately, once you finally suffer the pain of getting the 3 connected, you are done and will never suffer the pain again.

Other than the L bracket the thing went together exactly as the manual said it would. Haven’t played with it yet but at least it is together.

Yeah I had the same experience putting it together yesterday. Lots of parts and screws still left over which was kind of strange.

The allen key also got on my nerves, since the short end is super short, so you can never just tighten with the short end. I also have a Snapmaker 2.0 and they decided to mainly use 3mm screws, while the old screwdriver only goes to 2.5mm. Saying that it seems on the 2.0 I never used anything but 2.5 and on the new one never anything but 3. So why include all the other sizes instead of one nice version of the one you need. But anyways, the tools that come with it are actually okay.

Couldn’t figure out where the cover for that super flimsy fan cable is until I finally unpacked the box with the material and there it was.

First impressions:

  • The way the material is mounted is super weird. The holes are really far back and on either side of the machine.

  • The bouden tubes going to the dual extruder are rubbish. A lot of resistance. Also when you push in the material you have to push fairly hard for it to go into the extruder. Of course I pushed through one of the bouden tubes after only the 2nd time loading the machine.

  • Material holders don’t support large roles of material. I think I will drill some holes in the top and build 2 holders for big roles

  • Automatic z calibration doesn’t work. It does it, but when you go to print the head is hovering about 5mm above the print bed. Major fail for a brand new machine and a head that claims it can do automatic calibration. Did the manual calibration and it works now

  • Really surprised they still have basically no test models. I was expecting some cool things that you can print straight away, but no… nothing. On my FLSun V400 you switch on the machine the first time and have like 5 or 6 models to test print.

  • if you start up your machine and are getting lots of cryptic error messages: check the emergency stop. I had it pressed in by accident and it was showing me lots of error messages, not one of them was related to “emergency stop” or anything along those lines.

But yeah, looking forward to using it more. Good luck and have fun!

Had a few free minutes so I went to connect to network. Can’t do it as the special characters don’t come up on keypad. Try to find #, = etc. Can’t do it. Also getting error 2050-1 on startup. The message has no meaning. Upgraded firmware to V 2.0.16 using USB. Didn’t help. I reported the keypad issue as a critical defect as I can’t use this machine if I can’t connect to the network. No, I am not changing my network password because SnapMaker didn’t bother to test if their keypad worked. Order this thing in August. Finally got it last Friday and Monday. Was patient the whole time. I’m a lot less patient right now.


The L Braket is for CNC Milling/Carving. You can use it as end stop for your workpiece. You can find the description in the manual.

Same problem with Wifi special character.
Temporarly I created a hotspot with my smartphone.

And i got feedback from Snapmaker support:
“Wifi cannot input special characters. We have some restrictions. This will be solved soon.”

I have an issue with the assembly of my Artisan. One of the 2 Z-axis holders has probably a manufacturing defect. The holder is not in the center of the milling area of the base plate with the 2 centers and the 4 screw holes. THe holder is in contact with the border so it’s not possible to make a correct assembly.
Does anyone have the same problem ?
I have sent an email to the Snapmaker support but no return for the moment.

And 10 days later…no news from SM customers support.
So, my only one possibiliy, making by my self modifications on the holder to continue the assembly of my Artisan…

You paid a lot of money for the Artisan. If it isn’t right SnapMaker needs to resolve the issue for you rather than you modifying and ruining the warranty. I’m surprised at the no response. I have a simple question about special characters and they responded in 2 days. Might want to go out to SnapMaker and resend your note to support.

I have gotten ZERO responses to my questions and im on email 6 over the last month. Uggg starting to second guess my purchase!!

1 Like

Hello JustAHobbyist, yes, I agree with you but for the moment my Artisan is just a big piece of inert aluminium, no more…and after more than 6 months between the order and the assembly, I don’t have the patience to wait more.

Hello !
some news:
21 days after my first email…no solution from SM customers support (just 1 email in march the 24)
The issue is clear, the holes in one off the 2 Z axle holders are not in the right place.