A350 Leveling not working new machine!

So, I finally had a chance to get the A350 put together along with the enclosure. This was a big investment for me. I ran the auto calibration for the bed leveling process and it moves slowly from left to right, then sticks at the farthest right point and makes this horrible noise and just stays there. To say I am disappointed in something that seems so easy to do yet is not working is an understatement. I took great pains in putting it together correctly and even double checked all cables to make sure I had everything plugged in the correct sockets correctly. Everytime I turn it on to calibrate, same thing. Turn it off, turn it on, repeat, same thing… Moves all the way to the right, then gets stuck, makes a horrible noise and gets me really upset. I am a very techy person and this just doesn’t seem like it should be that difficult. Nothing was damaged, everything was put together as directed. We watched the video and performed all steps correctly including the enclosure.

Any advice on what I could be doing wrong? I’m installing the software now to see if there’s something in there that will allow me to reset the thing so it will work properly. Yes, I am a newb.

First thing that comes to mind is a defective limit switch in the linear rail responsible for movement in that direction (? I think it’s only one in that direction—I have an A150, which doesn’t double any of the rails). Try swapping it with one of the others and see if the problem moves with it.

Does this happen also when you jog the module using the Control app on the touchscreen?

Sounds like a limit switch problem as @ElloryJaye said.

What firmware version are you using? (have you updated it since receiving your machine)

Share some pictures of your machine. While you may think you’ve followed all the directions and assembled everything correctly, you might be surprised by how often that isn’t the case and something has been missed.


You said that the print head moves from left to right? I have an A350 but my print head always homes in the top left corner when looking at the front of the machine.

If your print head is trying to home in opposite direction then I would say you probably have the linear rails plugged in incorrectly. Make sure your X axis rail is connected to the X axis port on the controller.


@C.Harris homing wasn’t ever mentioned, they’re saying it’s happening while calibrating. It’s a limit switch problem in the rail, it just needs to be warranty claimed is all.

Correct me if I am wrong but the auto-calibration starts with the machine homing. IIRC there are no limit switches on the motor side of the linear rails and so the skipping due to a faulty limit switch only applies when homing.

I think a video of the issue from @Angel would probably be best to help us diagnose the issue.


@C.Harris saying that it only applies when homing is false, there are plenty of incidents where the machine failed to trigger the limit switch when not homing causing crashes, but not what is happening here.

You are correct though, there is only one limit switch in the rails, and the limit switch is on the opposite side of where it is failing to stop so it is not a limit switch issue. I believe that you are correct that it is a cable or a connection issue. Sorry for the delayed correction, I fell asleep lol.

Make a video and take some pictures of your device.
I guess, like @C.Harris, there is a faulty cable connection. Is the X Axis accidentially plugged to a false port?

Thats a fair comment, I shouldnt have made such a generalisation.

I suppose the gear skipping could also happen if the machine thought the head was in a different position than it actually was and the limit switch, which would normally stop the machine from travelling outside its operating range, fails.

Out of interest, do you know any other failure modes caused by a faulty limit switch? Always useful to expand knowledge of common failures

1 Like

@C.Harris if a limit switch is stuck on triggered state, the rail will only move in one direction which is away from the switch. If the switch is faulty, when it homes or is told to go to maximum travel it will just grind and try to keep going even though it has hit the limit switch, which I’ve seen happen while homing as well as during a job, there was a custom gcode where someone told the machine to go off the bed, home the head, then prime the nozzle in order to wipe the nozzle on the corner for a color change and the switch just happened to fail during the job and caused it to grind then the machine shut off.

I should’ve gone into more detail on my earlier comment, you are right that the switches are only used when homing, but it’s also false in the sense that it doesn’t have to home the entire machine, Marlin has a function to home just the head (mainly for IDEX printers but can be used for single head as well, also I have one) that is performed by the gcode during a job, so what I meant was the switches were not applicable solely during standard homing when we tell it to do so outside of a job, the gcode will just tell the head to home, though I admittedly am unsure if Snapmaker has that function enabled, but it was the only explanation for the crash that someone else had, there was no other possibility that would make that happen.


Double and Triple Check your cabling. I had this EXACT issue, and it turned out I had two cables swapped on my initial assembly. The stated behavior you describe isn’t the way a calibration works, as many here have said. (I had to send video to SnapMaker and they were able to tell which cables were swapped based solely on this behavior.) It’s always possible to have a bad component, but more than likely you made the same mistake I did, and plugged the wrong axis into the wrong port.

1 Like

I had exactly this problem, and the cause was my fault. This is what I updated my post in August 2020 with:

Resolved. I had made a stunningly stupid assembly error. I’m too embarrassed to say what it was.

OK, I will say what it was. I had fixed the Y axis beams to the bottom plate such that they overhung the front of the plate by about 5 cms. Stupid enough to do it, even more stupid not to notice!

Check your assembly.

@ecokestove thats a different problem, overhanging beams from assembling it wrong would not cause the grinding.

@Angel have you had any luck?

Well, it caused a bit of a graunching noise on mine as it tried to press the nozzle through the bed.
As it takes only a few seconds to check I would say it’s worth a punt.