3d print freezes on start

Hi all.
I’ve just purchased the A350 and am having trouble with the 3d printing.
when running any program, the machine positions and waits for the temperatures but then does nothing.
I have checked the Gcode and the first position command, places the positions at X-10, Y-10 and Z0. However, my machine stops at X-10, Y-8 so I’m assuming that is the limit of travel on my machine.
Is it possible to customise the post processor, so I can change the output to X-5 and Y-5 ?
I’m a toolmaker with many years of cnc machining so assume there’s a way to change some of the post processor settings?
thanks in advance.

Some questions:

  • Do you have the last version of the firmware installed?
  • Did you run autocalibration?
  • the positions your refer to are relative based on your calibration, so difficult to know where the printhead is located
  • How are you printing? from within Luban. Using the USB stick?

v3.12.3 /new
yes. ran the auto calibration.
it seems the 3d printing uses absolute position from the machine zero, so although the origin of the model is the centre of the model, the machine code starts at X-10, Y-10, from the machine zero then goes to approx the centre of the table.
I’ve tried a couple of different models but when gcoded, the start position always seems to be X-10, Y-10, where it then waits for the bed to reach temperature before proceeding with the print. As my machine can’t move to Y-10 ( stops at -8) it just sits there until I reset it.
I am printing from Luban, with wireless connection.

If I save the Gcode file, edit the start position to X-5, Y-5, load the gcode file into luban and then send it to the workspace it works ok.
If I could alter the post to use X-5, Y-5, I wouldn’t have to do this.

3.12.3 is the version of Luban. Not the version of the controller firmware (swipe from right to left and check in the settings)

Can you post some pictures & screenshots. It feels like there’s some other issue.

currently running a print so swipe doesn’t work.
here’s a couple of screen captures on my laptop.
sorry, I had to merge them as being a new member, only allowed 1 upload!??
Shows the wait for temp. point on bottom left (X-5 Y-5) changed from X-10 Y-10

To be honest I don’t really have a clue what could be causing this. The homing procedure should determine the maximum travel distance and base the position of the print head on that.

As your current print works it looks like there’s nothing major wrong with the assembly of the machine. (maybe post a picture when the print head is at the start position (so the X-10y-10) and how the rails y-rails are mounted.

Maybe someone else can give a suggestions

thanks for taking a look.
I’ll post more tomorrow.

Hi brvdboss. checked the mountings etc. all correct to manual.
controller version is V1.8.0.1_20200603.
snapshot of Luban showing the gcode loaded to workspace and the start position.
Tried re-calibrating, but still the same.
I don’t understand why always starts at X-10 Y-10, which is outside of the worktable.
I’d have thought the start would always be at zero or greater.
where does your machine start on a print?

I would suggest upgrading to the last version: Snapmaker Luban | An Intuitive and Powerful 3D Printing Software - Snapmaker
Current version is 1.10.1

Before it starts printing it always pushes out some filament and then travels to the start of the print. This first few centimeters are dropped outside of the printing area and by moving close to the surface towards the print start it get’s “torn off” so it doesn’t get stuck on your print and possibly mess with the bed adhesion. I think most people are sitting there ready with tweezers to pull it off anyway.

But the prints by default start at the -10 location. So that’s the same for me.

So my first suggestion is to upgrade to the last version of the firmware and try again (go through calibration etc).
You just put it on a USB drive and then select the file to start the upgrade. In the newer version of the firmware the controller can check online by it itself, but that version still needs to be upgraded manually.

thanks, I’ll give it a go.

there is a thumb drive in the snapmaker toolbox, that looks kinda odd, incase you dont have one handy.

That seemed to do the trick.
many thanks for your help.
great forum.
I’m looking forward to learning what can be done on this versatile machine.
I’ve seen many comments stating you can by 3 separate machines for less, but when your limited for space, this seems great.

I’m having the same issue since purchasing my new replacement printer head. The sensor broke off of my old one after several months of use, now this one is stopping and freezing in the beginning phase.

This thread was resolved with a firmware update. If you have tried this and it didn’t work, please make a new thread with more information. (such as gcode that is causing the issue, whether this started right when you got the new head or if worked for awhile before having issues, when it’s freezing, etc.)