10w Laser Manual Origin Settings

Hello everyone in the forum.
I finally received my 10W laser module.
Calibration and camera calibration have been completed.

I put the G-code on a USB memory stick and tried to do the origin manually, but I tried to indicate the origin with the laser beam output at the lowest power.

However, if I switch to jog mode with the laser beam emitted, the laser beam stops and the origin cannot be set.

Is this a problem with me alone or is it the default?

I want to run G-code manually via USB without using Luban, but I cannot set the origin.

Does anyone know how to do this?
DeepLで翻訳しました DeepL Translate App for Windows, macOS, iOS, and Android

When you start the file (not the control screen) it will ask you to set origin and let you move it around with the laser on. You can also forgo it altogether and set the origin to machine coords.

I have a guide on it here.

By connecting Luban to the machine with a USB cable, the origin could be set while laser output was performed.

I have tried LightBurn, but am having trouble because the Y axis is reversed.
The Y axis setting in Snapmaker seems to be ± reversed.

How did you guys solve this problem and are you using LightBurn?

1 Like

From what I’ve seen on the forums, they’ve disabled being able to jog with the laser on due to “safety” (see below)

With lightburn, is there not an option to mirror an axis? (I don’t have it in front of me at the moment)

bobby4718, thanks for the reply.

I wonder if Snapmaker has officially made it so that 10W lasers cannot be used to set the work origin while outputting about 0.5% of the laser from the touch panel for “safety” reasons…

I bought LightBurn yesterday and have been trying but the ± direction of the Y axis is reversed and letters etc. are reversed.

I will study LightBurn some more, but is there any way to deal with the Y-axis being reversed?

I don’t know if it’s a luban only thing (if you’re running it via Luban) but when I send a file to my snapmaker with the 10W laser and start it locally, the laser comes on at minimum power during the ‘set work origin’ phase. I can jog it around and set the origin as normal (though it’s rare I do it this way, I set it via my project). The only time I notice the laser turns off is if I turn it on via the control app, then try to jog it, then it’ll turn off.

Thanks for the reply, Skreelink!
I have confirmed that the origin setting and height adjustment can be done interactively by pouring the G-code file directly through the machine’s USB.

I see that I can also check the laser output by setting the origin.
Thank you very much.