Z-Offet with multi passes not aligned?

Hello everybody,

I am facing a strange problem. Installed my new 10W module (I LOVE it!) and tried cutting stuff. When doing multiple passes with the same z-axis setting it’s perfect. But to cut through even thicker material I’d like the laser to go down a bit. I assume that this is the option where you can put millimeters to go down between passes, right? Ok, having a “0” here and doing 2 or 3 passes is great. Putting a 2mm here and having 2 passes gives me a perfect cut in the first pass and and a cut with a 1mm (!) offset in the second run. I cannot think of anything being responsible for this but a not 90 dregree angle between the head an the plattform. But if 2mm down is giving me 1mm off is an angle that I assume that one could see that even without measuring.

Any hints?
Thanks so much! I appreciate!

I recognized that when I modify passes from the default Luban introduces the “z axis step in mm per pass” field. Setting this to zero is - like expexted - also giving me accurate results. But again: 1mm step in Z gives my 0.5mm off in Y, too.

Something similar happened to me today (just setting up the 1,6 W module)… second pass misaligned in X by up to 2mm.

You can check the gcode to see if the path is exactly the same before and after the Z drop, also what does the preview look like in Luban when it shows the path preview? Are you using the camera? I’ve had things skew when trying the camera so I never use it.

The only things that would cause a shift would be either: it’s part of the gcode, or a missed step during fast travel back to the origin between passes.