Z hop height, overstepped out of the cube


Found the following bug.

When I try to activate Z hop height 1 mm I get following error. That Gcode overstepped out of the cube.
I am printing a item that’s only 3mm high.

Best regards Henrik


I have the same issue too.

same here. new problem with an update?

If you put a negative value in the Z Hop Height, it will work. I think someone used the wrong math symbol in the programming.

1 Like

What version of Luban are you using? I just sliced the same model (or at least close to what it is by your image, an Australian trolly key) enabled Z-hop and it generated fine. I’m testing out 4.1.3, the latest released Dec 26th. I even set Z-hop to 1.5mm with no problem. However, I would suggest downloading the latest Cura and looking into how to use it since Cura now includes Snapmaker profiles built in.

Luban is actually built on an old version of Cura (since it’s open source) just stripped down and not as powerful.

lol, well, I submitted a support ticket for this and they merged it with a ticket I had open about my brand new printer module oozing PLA all over the place, so IDK what that means.

@Skreelink 4.1.3 over here as well. :man_shrugging:

:rofl: It’s a bug then. Negative value is down not up.


I didn’t update to the newest. Because all the problems I have heard people are having.

Hopefully it’s solved in the new update because my Z hop don’t work and not even bit the negative value.

I admit, I haven’t actually used luban’s slicer for 3d printing. I use Cura and Prusaslicer. However, I do keep both versions around despite being a horrible software. I use Luban 3 for my laser projects, as 4 has too many bugs and at least last I checked, doesn’t produce a working thumbnail. Luban 4 is for the rotary module, which it still messes up and I wish I could afford a paid F360 sub so I didn’t have to.

To have both versions at your disposal, download the latest version 3 from github, and your flavor of 4. During install, customize the install path (I just added a 3 and 4 respectively). I then made shortcuts to each, Luban3 and Luban4.

update on the support ticket - known issue, they recommend i downgrade to 4.0.3

Tried downgrading back to version 4.1.1, still have the Z-hop issue, so it’s not new in version 4.1.3?