Y Direction Layer Shift After Pause/Filament Change/Power Recovery

I searched the topics and couldn’t find one related to this.

Has anyone else experienced a Y direction layer shift after a pause / filament change / power recovery?

I have experienced it two days in a row now with two different STL files.

The first time I needed to pause to change filament color. The second time there was a storm rolling through last night so I paused my print and then cut the power so that I could do a power loss recovery this morning after the storm had blown through. Both times, once the print returned to work it shift a mm or 2 only in the Y direction.

I have noticed this with a power failure, but not for a filament change.

Hey AU_Mech,

I think it’s hard to change the filament without moving the printinghead.

Is the shift every time on the same side?

I would be surprised if the head moved by as much as 1-2mm as the OP claimed when changing filament as when the SM is on the stepper motors are engaged preventing movement. Also he said the shift was in the Y axis which is the bed itself, so shouldnt be moved during a filament change either.

I too have experienced layer shift the one and only time I have used the power recovery feature and it was approx 1mm shift but in the X axis

Yes my shift both times was only in the Y direction (bed) these last 2 times. Pictures below of a side view of the from and back of the bracket.

Also, I was under the assumption that Snappy2 uses absolute positioning and that it knows where the print head is at so that it accounts for accidental movements of the print head and returns to the absolute position when returning back to last known point of the gcode.

image image

I have seen both X and Y failures to return to position after power off. I think it depends on what is moving when the power off happens.

1 Like

It likely has to do with the direction of travel and speed just before the power cut. There is obviously momentum which carries through the point of power loss, if the printer is completing a travel move at 150mm/s (for example), I wouldnt be surprised if the carriage moves 1-2mm before coming to a stop after the steppers lose power.

I could agree with this assessment.

But here is my issue with the pause & power loss features. During power recovery and even when I rewrote my gcode, to return to the last now position for X,Y,Z, a G28 (Home) code is performed at the very beginning. This should reset the position or any prior movements at power loss. At this point the machine should be correct again and then return back to the last position which should result in no layer shift but it still shifts.

Likewise, during pause, the machine moves to X-10, Z330 (upper left) for filament change. And should re-home (G28) prior to resuming that should help reset the position to continue exactly where it left off.

I think it is related to firmware, just not sure how to fix it.

Hi @AU_Mech please send me the G-code file so that I can print it on my own. This is a firmware issue and I will forward to our firmware engineer about this. If the problem is confirmed, it will be repaired quickly in the coming version of firmware.

1 Like

This is not acceptable, and we will try to find the solution about it.

Edwin,

Thank you always for the help.

I have had it happen with 3 different files where I have had the machine stop (related to my other filament runout issue that you and I have been working through), pause for filament change or power loss. I have found that the issue is more prevalent with power loss recovery (also because I had to use this to recover from the runout issue that stops the machine when running from the serial connection). My last file was a 36 hour print with a fast slice (not sure you would want to test with that one :rofl:. I can share the one that didn’t take the longest to complete. But really I think any file that you try those three modes and restart should try and help diagnose the issue.

All of the files are for a design that is patent pending file for a customer so I can’t share it publicly, how would you like me to share the gcode?

You can share the G-code file with Google Drive or Dropbox. I will try to print them and test the power-loss recovery by my own tomorrow.
Looking forward to your reply.

Thank you. I sent you a message with the links.

How fast were you moving? Is it possible that your axes were gradually skipping steps and were realigned when the power reset came?
Then the angle of your object should be off.

Why Z axis value is 21.32? I tried it to print it but failed three times until I find that the start code of this file is abnormal.

Here is the picture

That is from my modified file I sent you when I had to rewrite my gcode by hand to resume my print because I wasn’t able to resume with power recovery. It starts at layer 88.

The other file I sent is my original that starts from layer 0.

i have the same problem
its not depends on file or g-code
i tried to set print pause and then reconnect power
i tested it many times with many different models and software (cura and snapmaker luban)
result still the same - after power reconnect (with print pause or not - no matter) the Y direction is shifted on 1-2 mm

maybe its a problem with syncronization between two bottom rails
because i have strange sound when print bed goes to the end of Y-axis on start calibration
looks like some thing in rails hits the border