Worse product go with a user friendly machine

Snap Maker is overrated and over priced and ours is an oversized table decor. My computer connects — tells me file shared successful, but isn’t there at all, then tried the USB option and same thing. We printed 3 - 3d projects after we assembled everything, but could only print what other people shared. Now, that I understand design software a lot more I wanted to make things, but since we added the quick swap and enclosure we were trying the projects that we had success with from when we got the machine. NOPE, continues to say no files. We successfully changed everything we added in the menus — I am so angry that we bought more crap for it — when we should have waited to see if we really could get plenty of use out of. My friends all thought they could figure it all out. There have been tons and tons of people claiming they can figure it out — NOPE. They all learned not to buy a Snap Maker. That’s why I have been seeing an onslaught ads on facebook marketplace. The sad news is we spent thousands and a common list price for what we have is $400. I might as well keep my table decor so at least there’s a story behind our lesson.

This story is all too familiar. Such a shame; Snapmaker has such large potential to be something great, but falls seriously short of it, all in the name of profit for its Chinese overlords who care for little else. Sorry you had to experience it too.

Did you ask snapmaker support for help?
If you transfered files to the machine, was the correct toolhead connected and detected? (visible on the main screen with a green dot)

The community is willing to help, if you like.

That the SM 2.0 can do great work, you can see at the showcase pages. But like all of these products there is a learning curve. I have another CNC milling machine too. That doesn’t works from the first time. I think about buy a Sorotec milling machine (to mill alu). I’m 100% sure that the first try not the result gives that I want.


This is printed on the SM2.0. The whole

Made with octoprint on a raspberry pi. Draw in sketchup.

With the 40W laser and Lightburn on a laptop. Draw in sketchup.


2 faces to mill. Made from 5mm and 3mm MDF.

So, yes and yes. My computer said “sent successfully” but on the tablet there are NO FILES. If you re-read my post – I mention just about everything we have done. The correct toolhead, did the calibration, set the temperature of both the toolhead and heated bed (using the same setting we had success in the past with). I mean it took us through the menu because we added quick swap and enclosure and they were on the list in green. So, I have everything correct. It is having difficulty with the transfer of files (I am using the same ones from the beginning we had success with). I tried both wifi and USB. The USB was a SnapMaker one that had never been used.

I am so at a loss. We have had many tech savvy people come in and try to help us. We are all at a loss.

I never expect anything to turn out a 100% on the first 5 if not more. Crafting is a fickle and things happen outside of our control and too many variables that can cause that to happen. I do expect that when I have a menu that is green – it means I have things ready to at least start. There is a communication issue that I have no idea how to fix or even work around. You would think that if I removed my computer from the equation; that at least using 100% SnapMaker items would at least begin the start up process. All I can do is move up and down and sideways. That IS IT.

BTW, nice pictures. I wish at some point I can do all that and more. I am looking for a different machine to invest in – Just stinks that I have to get separate machines for what I want to do.

I don’t believe it has anything to do with the Chinese Overlords. SM is having a communication issue that I have no idea how to rectify. It’s probably a setting, something I missed, or is broken. I need to just walk away and stay away from it before I end up throwing it away for a few days.

Have you tried to reset to machine defaults and starting with a clean machine?

Do you have the last firmware, where you can select the quick swap and bracing kit?

I never place files on the SM. They are on the laptop for laser (Lightburn) and milling (not used yet with Deskproto) . Like said on a Raspberry pi for printing.

If you don’t see the file, select sort on date once again. In most cases the file appears on top of the list.

Thank you for the insight – file is completely empty. I wiped the whole thing out to start completely over.

Yes, Yes, and lastly mine are all on my computer as well. I send the files over to SM and my computer states “file sent successfully” and I look on the tablet to find the file and it is completely empty. I wiped everything off of it, updated all the tools, updated to quick swap and enclosure. What is Lightburn? and milling is CNC? We have NEVER done anything other than 3D printing and that was well over 2 years ago. I wanted a fresh start being we upgraded several items and it didn’t seem fair to keep outdated and older files, that probably aren’t up to date. I am trying the products that are on the Luban main screen. I haven’t even tried any other files yet. Seems silly, but I really wanted a successful start so I can learn along the way. I can’t even imagine laser and CNC projects if I can’t get simple provided 3d projects started. I can see why I am seeing an uptick listings in FB Marketplace and eBay, because I am guessing I am not an isolated case. I will do more research in a couple of days – I am finally getting over my anger. Not really sure what else I can do to fix or change anything, but being we spent a fortune on this it does deserve more time, just not NOW. If you have any other ideas that I can possibly try I am willing – it may not be tomorrow, but I do give you my word I will try.

Thank you for the insight – the file folder is completely empty. Not only did I send it from my computer, but I also used the USB drive from SM and NO FILES can be found. It is wiped clean. I put the SM USB in a different computer and the file is on the USB. It should be on the SM, since it is on the USB.

Milling = CNC. I will use Deskproto to do that. I have that program from my old CNC. Lightburn is a program special to use with laser.

In the begin I have work with the files on the SM. Not always with good result. All that files rest on the SM.

I still try to understand what exactly goes wrong among all your ramblings - do I understand right: You prepare some 3D printing file, send it to the Snapmaker and it does not show up on the touchscreen? Here a few questions:

  • Do you use Luban to send the files? If not, how do you send the files?
  • Do you use Luban to create the GCode, or do you use a different slicer?

Based on your answers, I may have follow up questions :slight_smile:

One thing to check: The touchscreen has “hard coded” filters for files, so if they do not have the right file extension, you will not see them. So do the files you send over for 3D printing end on “.gcode”? if not, that already may be your problem. Do they end in “.stl”? Those you cannot print directly, you need to slice them first.

1 Like

usb sticks has to be fat32 formatted. Maybe that’s the problem with your external drive?

I encounter similar problems since several months. Sometimes this helps: go to the wifi setting on the console and reactivate the wifi.

Regards, Dirk C. Hoff

All I am trying at the moment is to print from Luban those that are on the main screen – the vase, chess piece. They are ending gcode. I haven’t even begun to try other software (I wish and that was my entire plan all along). As soon as I open Luban to pick what kind of project – I am choosing the vase. It loads into the Luban software, I do NOTHING to the file other than save it, generate gcode, connect to SM, file sends successfully, go over to SM tablet, click on file (all the tools and heat bed I have changed the settings to what works for our machine all ready done), and there is one file labeled workspace (I open it up and its nothing), other than that – there are no files!!! Someone commented on formatting the USB – that has been done years ago and I was easily able to locate the file on a completely different computer - so that’s not the problem either.

I absolutely think it’s a communication issue on the SM – I may not be that tech savvy, but you don’t have to be when you followed everything to a T and still nothing on the SM side.

formatting the USB – that has been done years ago and I was easily able to locate the file on a completely different computer - so that’s not the problem either.

I’ve tried both methods to send to the SM still – NOTHING

Thank you anyways

Funny you mention that!!! The SM was originally set up to our old internet provider.
We wiped everything and started from scratch (multiple times). Now, we have fiber optic!!! It does NOT like our fiber optic - it sent error code after error code, so we set up a network thingy just for the SM and away it went. We did all the updating, including the tools, the quick swap and enclosure. So we know fundamentally, the SM is working. Receiving the project through the tablet is where the issue is, however the USB is on the one of the Axis, it still doesn’t get the project.