Unresponsive (Not Connected Warning) at 100% but

So I tried a longish job yesterday that supposedly ran about 14hrs. It should have ended in the middle of the night sometime.

I checked the job this morning to find that the screen showed 100% complete with a warning triangle saying something about not being connected and did I want to reconnect. I tried to reconnect three times and it always came back to the same warning.

Also, the nozzle was still literally attached to probably the last corner of the project it printed, and had just not retracted out of the way.

But the real kicker was that the bed was very warm. I didn’t know how warm until I shut the power off and rebooted the system, and then I saw the temp coming down gradually passing through 83c. And I had it set to 60c for the project while printing. So naturally that’s a concern.

The project did get a little warped from the excess heat.

I am using firmware 1.6.0

So if anybody has run into something like this before please let me know. During the setup to run this particular print the only thing I did prior to starting was to change the bed heat down from 70c to 60c before printing (using the controller). I don’t know if that had any bearing on this.



Hello Mike,

I had exactly the same issue last weekend. I got my SnapMaker 2.0 last week and assembled it on thursday, started to print then.
Two prints finished without problems but at the end of the third the noozle stopped what seems to be the last bit it printed. The nozzle temperature fell and was already cold as the PLA was when I looked for it.
Warning and behaviour was exactly the same as you describe it.

I managed to get the print from the bed and rip it of the noozle.
But the bed was very warm. Bed temperature was set to 70c for the print (which it was while printing) but when I found the machine in this failure state the bed temperature was around 93c (according to the touch screen and my almost burned fingers ;-).

Leaving the error status and reconnecting did not work - I had to power off the SnapMaker2.0 and power it on again.

I’ll have to look up the firmware version and will post it later.


This is disconcerting. I hope that SM will be able to correct this issue. Temperature runaway for a machine like this could be very dangerous.

Hi Mike,

Here is Edwin from Snapmaker Team.
Sorry for the late reply first.

We have noticed that you have posted in the Forum about the problems you encountered withe Snapmaker machine.
1, Not responding and re-connect issue.

Already known and happens widely. We will review all that cases and fix that in next version of firmware.

2, Heated bed issue.

Could please offer more info to us so that we can troubleshoot it.

  • When did the bed temp runaway after you started a print?
  • Did the temp value surged or declined, or stopped to heating up?

Send me your email address and we can contact with you from the support system, where we can record the solution.

Phenomenon: The print module stops at the final point of the print and the temp value runaway after rebooting.

  • we are fixing this bug and will release the next version of firmware. The heated bed temperature can reach 110℃ or so, and the power supply module is also protected against short circuits.
  • If this issue happens again, please do as follows to record the error.
    • Be careful and do not touch the heated bed because it is hot.


  • 1, Be noted that there is a breathing light behind the main controller which represents the working status of it. Please check if the breathing light is working.
  • 2, Try to connect the machine with the PC via the provided USB cable. Check if you can connect the - machine with the PC successfully.
  • 3, If yes, please enter the command “M105” in the console and record the info by making some sreenshots.
  • 4, Then enter command “M2000 S0”, and do screenshots as well.

Send the images to the support.snapmaker.com for further assistance.

Sorry for the inconvenience.