Too much support on model

I have two files that are near mirror images of each other. They’re meant to interlock to make a ceiling register cover that’s larger than the bed of my A350.

Luban treats one STL file, lets call it Register RIGHT entirely as expected. The only support is on one corner where a bit needs to be higher than the surface of the bed.


Luban treats the other STL file, lets call it Register LEFT, differently. Luban adds support in all the areas that are supposed to be empty. There is no reason for that support, as there’s nothing above. I can’t find the difference in the two files that causes the different behavior.

Any ideas?

That’s odd. Can you upload the object files? If not, try uploading to google drive and linking them.

How was LEFT created? I’m guessing it was originally one objects that you cut in half. Would it maybe work better to actually mirror RIGHT, and print that? The interlock probably makes that difficult, as it’s harder to design something to work that way.

The latest Luban lets you change the overhang support angle, and edit support. I’m not entirely sure how the edit works, but it should let you mark areas that should not receive support.

I ended up having to recreate LEFT and RIGHT vice just cutting the original file in half. At the time, I couldn’t get the split function to work. Both were created in Shapr3D on my iPad Air 4. I can’t think of any processes I used on LEFT that was different from RIGHT. Draw out the basic shape and then extrude up. Camphor edges, draw an extra box and reverse-extrude up to make an “upper tab” vs a "lower tab.

Basic stuff. I’ll see about linking files after dinner.

I’ve found I can reliably print much steeper overhangs if I use a lower layer height. I can print 50º with a 0.2mm height, and 60º with a 0.1mm height. If you can print the overhang, just disable supports. Even if you can’t, sometime it still works with some texture issues. Like the overhang will be really wavy on the bottom, but it still gets printed well enough for the upper layers to print fine.

That’s cool, but that’s not my issue. I’ve got the files uploaded to a drop box folder, now I’m trying to get it to give me a link to post here. Something isn’t cooperating.

When you see the files, the one with the hexagon detail is RIGHT and is working fine. LEFT has the atom detail and is not working fine. Also, in setting this up, I discovered that LEFT .stl is 3x the size of the RIGHT .stl. No idea why.

Got it. Here’s a View Only link to the folder with the requested files.

As you can see, the Luban workspace for LEFT includes lots of extra material not in RIGHT. I can’t figure out why LEFT is so much larger than RIGHT, or why luban is putting in so much more material than designed for.

Upon opening the files, Luban 4.4.0 prompts me that both files appear to have errors, and would I like to correct them? I said yes.

Before slicing, zooming in on the bottom of LEFT, you can see the rings are just a bit proud. They’re not quite flush with the bottom. So the layer 0 is a bunch of rings and support material, and layer1 is the bottom surface. There also appears to be some weirdness with the meshes in one corner. I’m slicing at 40% scale at 0.2mm layers:
Layer0 preview:
Screen Shot 2022-10-25 at 2.11.00 PM

Layer1 preview:
Screen Shot 2022-10-25 at 2.11.39 PM

There’s also some weirdness at the top. Before slicing, the rings are open at the top. After slicing, layer14 shows the rings being covered over, which is why the rings are full of support material.
Screen Shot 2022-10-25 at 2.13.18 PM

It appears to be a single layer at layer 14, as layer 15+ don’t go inside the rings again. That layer covers everything except a single ring in the corner. Layers 2-6 seem to be doing some odd things to the plus shapes. If you click on the layer slider, you can use the up and down arrows to move up and down a single layer at a time. I use that a lot when I’m evaluating models to see if they will need support or not.

I retried both without having Luban repair the models. That actually looks better. The layer0 mesh weirdness is gone, but layer0 is still just ring outlines and layer1 is the bottom surface of the model. The layer14 sheet across all-but-one rings still exists.

The two rings in the corner with the through hole connector have taller atomic logos inside the rings. I’m unsure if that was intentional or not.

If I slice using Cura, I get a warning that LEFT has some mesh issues and is not watertight. There are some random circles in layers 4-6, and this time the solid layer is layer16. So I think you’ve got some mesh errors in there that need to be fixed.

I’ve personally never done mesh editting, but if you search the forums for “mesh repair”, there are a lot of good posts. At my personal skill level, I’d probably just start from scratch again, but YMMV.

I just installed Luban 4.4.0 a few minutes ago. Before that, I was on 4.3.2. I understand everything you’re saying, but I don’t understand why Luban was generating all that extra material. I didn’t design that extra material and it’s not in the .stl file. The octigon and atomic logos are separate files I got instead of drawing them myself. They came as mesh, and I can’t union them with the overall structure.

Tomorrow, I’ll try regenerating the LEFT side by duplicating the RIGHT side and inverting, then altering the overlap tabs as needed.

I took a look at your stl files, and I can see some issues on the LEFT file where the symbols are in the holes. It seems like the symbols did not properly combine with the rest of the model, resulting in the weird geometry that is probably giving Luban issues. For example, I attached a picture showing gaps within the model that I am pretty sure is not supposed to be there (Image 1). It also looks like this resulted in the bottom of the model not being flat. I attached a second image from cura where the light blue represents touching the buildplate, and red is not (Image 2). My go-to is usually to fix mesh issues in 3dBuilder but in this case it messed with the geometry, so fixing it in your 3d modeling program is probably your best bet. I hope this information helps!

Image 1 - Gaps within the model:

Image 2 - Non-flat bottom:


Thank you for the advice.

This design is meant to be a ceiling register cover. I didn’t think those little gaps mattered. Air is passing through either way. I didn’t realize the atom detail was not quite flat, though.

A bit ago, I duplicated the working RIGHT model, mirrored it, and then reversed the two tabs so they’ll fit with the tabs on the RIGHT model. I’ll see how that works with Luban.

The existence of gaps isn’t an issue, but these specific ones sometimes indicate “Zero Thickness Geometry”, a type of mesh error that doesn’t play well with software - slicers included. 3d modeling just has some weird quirks sometimes that cause headaches, then never happen again.

Hopefully duplicating and mirroring works!

I haven’t tried printing the duplicate yet (other projects in line) but I notice the duplicated file is about the same size as the RIGHT side that worked well. So I think the extra stuff that was causing an issue is dealt with.

Sounds good, let us know how it turns out!

Except for forgetting to swap the peg&hole in the corner, but it printed perfectly to design.

1 Like