Targeting Cross Hairs

I have just recently taken delivery of a 40W Snapmaker Ray and enclosure. All has been assembled and I have started to try engraving.
One issue I have, is when setting the cross hairs at the origin of my workpiece and then run a boundary check everything seems fine (the boundary lies within the workpiece) I then go to engrave and the job is out with the boundary.
I change the boundary to a dot and run the boundary seems to be fine but there is no centre dot to align with the workpiece. It seems to be about 20mm out, both directions.
Is this as it should be, or is there a way of establishing a centre spot that I can align with the centre of the workpiece.
Hope I have explained this well enough
I also have a A350 Snapmaker 2.0 so am not a total novice
Any help would be appreciated

are you using Luban or Lightburn as software?
As there is a offset between the crosshair and the laser this could let you run in this trouble - at least if I understand you correctly…

Thanks for the response
I am using Luban, apologies I should have said.
Yeah, that seems to be the issue. Seems to be about 20mm offset in both X & Y directions.
Is there a method of correcting this. It would be useful to be able to project the job centre point onto the actual workpiece

An offset in Y direction would be normal but as far as I know the crosshair pointer has no offset in X direction… So actually I don’t think this is the source of the problem.

I’m using Lightburn but as far as I remember Luban is a bit special when you set the work origin - maybe you have to use some other setting there - have a look at Snapmaker Ray 40W work origin problem .

Otherwise give Lightburn a try (30 day free trial) and see if the problem is the same wheb using this software. The Lightburn settings are downloadable at the Snapmaker Wiki…

I wanted to give my 2 cents on this topic. The Luban software doesn’t provide enough control of the machine. Lightburn gives me the ability to remove the crosshair offset and turn the laser on for alignment. This was a gamechanger since when using lightburn the first time you run a job the crosshair didn’t return. The only way to get it back was the use the job button (hopefully you have a small job that was sent from Luban) or turning the safety key off and back on. This started becoming tedious so I opted to use the laser beam and remove the offset. Now I know without a doubt I am within 0.5mm of where I need to be. It was difficult to know with the light scattering crosshair and was often very slightly off center (perfectionist in me couldn’t cope with that lol)

Just know that when you use Lightburn, to have a great experience you will need to stop moving the laser head with your hand and use the controls in the software. There is a fluke between the Lightburn software and the machine. You will have to tell the machine to go -400 on Y (G10 L2 P1 X0 Y-400) then the Lightburn control and location, origin and absolute position work as expected.

Credit to @Turbobulldog for figuring this out. Here’s his original post link: