Svg not working after update to 3.15.1 (solved)

Hey there,
i used 2 svg files in the laser environment over a month. After updating the software to 3.15.1 the file “svg working.svg” is working fine like always. I also can drag file “svgnotworking.svg” into the software and I can see it until i press bearbeiten (process). the file is not shown in this step so i cant create a toolpath.

I tryed several setting when creating this svg but the result is always the same. The files are created with adobe illustrator.

any ideas?

supplement: as a new user i’m not allowed to upload the svgs. so hopefully i can get help without them.

Luban only implements parts of the SVG standard, not the whole thing. Chances are that either you’re using a construct it doesn’t support, or Illustrator is doing something behind the scenes. Make sure your file only contains simple paths.

We really do need the file for better diagnosis.

1 Like

Thanks for your reply.
The files contain only some simple lines. since i posted i also tryed to save the svgs in affinity - same result.
i uploaded them to wetransfer:

Your “svgnotworking.svg” showed up for me in 3.15.1 after “Process”—it’s just that it showed up in the same almost-invisible pale grey as it does before processing. I was able to select it (by clicking semi-blindly near the middle of the display) and create a toolpath.

1 Like

Thank you very much, i could solve the problem.

Based on your information that the file is working for you i guesses the problem is not the file.
I installed the the software on another machine, opened a new session and the file worked.
Back on my workstation i erased luban, reinstalled it and then used not my saved luban file, i made a new one.

So i guess either the updating process failed in some way or my luban file from the outdated version caused the problem.