Importing SVG into Luban 4.11.0 does not work properly


Yesterday I reactivated my Snapmaker 2.0 after a long time (>1 year). I updated all controllers and installed the new version of Luban (4.11.0).

As first task I tried to import an Inkscape svg file – but the result is not usable:

  • Luban did not recognize the single objects. I added layers as described but this did not help.
  • The objects are not filled (text and icon). This issue is already described in another post but not solved there.

Does anybody have an idea/solution for one or both issues? That would be great!

Thanks in advance!



I am using Inkscape without issues, but i never tried multiple objects so far.

For importing SVG i need to switch from vector to half tone in Luban, otherwise the object is not filled. But that’s the nature of SVG.

Thank you for this hint: I tried half tone and this happened :neutral_face:


Regarding the single objects: Luban does not seem to be able to resolve the SVG into individual objects. For getting the letters filled: I’d select Vector mode, and then, when setting up the toolpath, I’d select “Fill” with Movement mode “Line”. That should yield acceptable results.

Lightburn has much more flexibility btw. - if you happen to laser a lot, I’d recommend investing the few bucks.

Tested with a sample font in Inkscape, stored the selection as “Inkscape SVG” and imported it to luban.
Was not filled, but once i changed it to Half Tone, this happened:

Seem to be as expected, eh?

1 Like
  1. Tested with two fonts in Inkscape (Inkscape 1.3.2)
  2. stored selection as “Inkscape SVG”
  3. Imported into Luban (4.11.0)
  4. changed to Half Tone (both objects)

This happened:

Then i can’t help. Good luck finding a solution

Inkscape is a free and open-source vector graphics editor

You get what you pay for. Use Illustrator. I don’t know what those 4 settings are for, but I’ve never had to touch them importing an Illustrator SVG.

As I said: Use Vector, then fill. To illustrate: I created a testfile with Inkscape (which despite(?) being free and open source is a great program!) and loaded it into Luban. It does not look filled in the work area:

But when you create the toolpath with Fill/Line:


And then you preview the toolpath you’ll see it is filled:

It is filling it by doing scanlines. Here’s where Lightburn has its advantage - you can use Offset Fill, which yields much nicer results:

I use Luban to fill engrave then an outline path to clean up the edges. Will achieve results comparable to what you show in lightburn offset fill.

1 Like

Congratulations. The most useless statement so far.