Snapmaker official response to print head gouging?

Go through this video, follow the directions to build the mesh in Excel. This will give you an idea on how far off your bed is. If it is more that 1mm then you may have a problem that requires shims.

If you are using Octoprint, install the bed visualizer plugin to see what your beds deviation is.

My bed is about .7 and I am able to get some good fairly large prints. I still have a problem using the whole bed though.

Just a side note on shims.

I used an 0.015" shim plate to level the bed, from a set of shim stock (McMaster-Carr) I keep in the shop. These are stainless steel shims, C40 hardness.

I did a test print, and the bed was level, tightened the four bed mounts a bit, and a few prints later I noticed the bed was high on the shimmed side … by 0.015". Removed the shim and the bed was level, and has been fine ever since.

The only explanation I can come up with is that there was a burr or some other protrusion on the high side that got flattened by the hardened steel shim. Same effect could probably be obtained with a stainless steel washer (4mm or #8 should do it). Grade 8 likely has too rough a surface.

The bed visualizer is the first thing I intend to use. I have also bought some precision levels to help check the bed surface.

I do not like how spindly the bed frame is, and suspect the coefficient of expansion could be different between the different arms due to casting or composition differences in the assembly. Even variances in the thickness of different areas on the assembly could cause uneven expansion. So if it was milled cold, the expansion would throw it out. I will definitely check for burrs or other manufacturing artifacts.

Funny, I used .03 and .05 washers to shim my bed. after a few leveling sessions, the bed went the opposite direction. I removed the washers and the bed is much better.

Cold, with OctoPi Bed Visualizer, I have 8.48125mm at 0,0 to 9.59201mm at 249,302. That is @ 1.1mm, which explains why trying to level it during the print exceeds the .5mm limit. Not sure why this is not a +/- value around a 0 point.

Newbie here. I have tried all of the above suggestions. It is still pushing the bed down hard. I am at my wits end. I’ve had this beauty since the middle of march and have not been able to do anything due to needing a new controller (which took a month of back and forth from a very helpful tech). Now all but the calibration is working. I am ready to cry at this point. I have the A350 my husband bought for a gift so, I need to have terms a novice can understand.

Hey @Steener, please make a new topic and show some photos of your device, to not hijack this thread.
Tell us what your problem is and if you ever printed with this machine.
Update your firmware to the latest version 1.12.1 (right now, i guess).
If you want so, give it a @xchrisd and i will come along, not loosing your post :wink:

Thank you I thought I did make a new thread, my apologies. I do have the current firmware update.

Scott & Christine St. Onge

Did you get this sorted or create the new thread? If so can you post a link.

Is it hitting the bed at the back of the bed when the head first lowerss after a homing?

If so your two y axis are mounted a screw hole to far forward. They have to find in the indent on the base plate.


Thank you for getting back to me. It’s working like a dream.

What did you change?

1 Like

It is really helpful to other people looking up problems if you post what happened to make your situation better!

1 Like

I have a question on the mounting of the 3D print head. In this response picture 2 shows your print head is mounted on the bottom of the x axis module, while in the instruction it calls to mount in the middle of the bracket. Mounting the way it calls it out in the instructions requires the x axis module to go lower on the z axis module which seems to cause a more jerky motion on the z response on 3 D print on the initial part of the build. Would mounting the head on the bottom of the bracket fix this?

It’s only mounted on the bottom bracket temporarily so he can access the screw to adjust the sensor.
If you’re having problems with the motion being jerky than you probably have excessive play in the brackets for your linear rails or some other problem with your z-rails. The motion should be consistent no matter what the height of your x-axis.


@xchrisd and I troubleshooted it with @Steener in a separate thread, the converters were swapped around and it started working.

Back to the topic at hand, @sdj544 the IR sensor conversion that @stewl wrote up is working wonders, I think if Snapmaker put an IR sensor on it the print head gouging would be greatly reduced if not completely eliminated. The stock z probe I never had come loose, but the fact that it can and does is a major problem point. The IR sensor is great for detecting the actual surface unlike induction. Although black surfaces are supposed to be the weak point of IR sensors, I tested it with the pei sheet and it still saw it.

11 March 2022

I’m using a A350 Snapmaker 2 .

The firmware has been updated to

My calibration procedure breaks down at point 5 and tries to push the nozzle into the plate until the bed bends and the vertical actuators skip and fail

The best I can figure is that the proximity sensor is marginal when at point 5 ( the proximity sensor hangs over and off the build plate ) Perhaps the Snap maker people can verify.

for example, this shows where the proximity sensor is located

When ever I try to find information on the proximity sensor on any Snap maker official website or forum I get the following


You’re not authorized to access this page

For now my snapmaker 2 A350 is an expensive brick.

If any one finds a fix , Im interested.

Your proximity sensor may be too high. I linked to the troubleshooting manual and mentioned the page number in this post:

And further down the thread are additional instructions that you should read before recalibrating.

They reorganized their help pages, breaking a lot of links, which is probably why you get that error on their website.

The proximity sensor is the black cube in the back right. So it’s still well on the bed in your video. There is a red led that should go on when you’re holding something metal under it.

Check this thread for official troubleshooting guide:

Double check your cabling and assembly. Make sure y-axis rails are centered on the bed and not hanging over.


Many thanks . Ive establised the proximity sensor works by putting the Snapmaker scraper knife they supply ( metal blade) near the sensor while its half way down and that stops the calibrate procedure. The nozzle then is seeking the print bed in mid air.

At contact point 5 when the nozzle tries to gouge itself into the print bed . Ive now put a small 1" x 0.75" magnet under the print bed (it clings to one of the bolt heads)

That’s now solved the proximity sensor issue - the nozzle no longer tries to destroy the print bed.

So the issue has been a proximity sensor , sensitivity issue.

Its a component design issue when you consider - all pages relating to the proximity sensor have now been removed and the print heads are euphemistically “sold out” (removed)
until they find a solution for this. Try my solution - simply quick, effective and repeatable.