Snapmaker 2.0 Firmware Update

Looking at Snapmaker 2.0 Firmware Updates and Downloads I see firmware updates. My Snapmaker 2.0 is on version 1.8. I’d like to use the Snapmake Luban 3.12.2 Firmware Tool.

On that tab, there are two options - Controller Firmware and Module Firmware. If I want to update to Snapmaker2_V1.10.1.bin which option do I use? Being a firmware update, I don’t want to guess as it’s not clear what protections are in place for using the wrong one.

Neither of them. The Firmware tool in luban is when you crate your won firmware via the github repository. Both packages will be packed into a .bin file which you then put on a USB stick and update the formware from the Printer screen by selecting it.

Check towards the bottom, the tool is mentioned there.

I did my updates via the USB menthod sofar, dont know if there is an alternative tbh.

Doe the firmware update process of SnapMaker 2.0 mirror the process of the SM Original? Searching the online manual in Luban (latest) produces no applicable results.

USB Method worked for me as follows:

  1. Copy .bin firmware update to USB stick
  2. Insert USB stick, power on Snapmaker 2.0
  3. Swipe right and choose Files
  4. Tap the USB tab at the lower right
  5. Tap the .bin firmware update file
  6. Wait for firmware update to complete (even if it says “0%” for a while… it eventually worked)

Is there a way to upgrade the firmware without the display? I can do nearly everything using GCODE commands, I also see M997 in the Marlin documentation. I just put the firmware file to an USB disk, and issue M997? Is there a naming convention I have to keep? What if there are more firmwares on the USB, which will be loaded?

Update: unknown command M997

M997 is a Marlin command, but the Snapmaker firmware does not use all available Marlin commands, and some of them are used for different functions than the original Marlin programming. This is one of the commands it does not use. Here is the official list of G-Code commands that it does use…

Also seriously wondering about alternative methods, as my usb port does not recognize any usb flashdrive on my printer. I’m stuck on the wrong firmware and can’t get back to my old firmware. Any solution to this?